Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

D3DX8

This topic is 5930 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey, I downloaded DX 8.1 from Microsoft, and I even went to MSDN and downloaded the 60MB "DX8 Developer Runtime", but I don''t see any d3dx8.dll. Many tutorials instruct me to use the d3dx8.lib in order to use the D3DX library, and I assume that means there is something called d3dx8.dll. But it''s just not there in the Windows/System directory even after downloading all that stuff! Am I seriously mistaken here? Tron3k

Share this post


Link to post
Share on other sites
Advertisement
I''m no xpert and I''ve never looked into the individual files but I do know at d3dx8 is a set of functions that aid in the development of d3d8 programs. Maybe it''s possible that the .lib contains all of the functions and it doesn''t need a .dll. Again, I''ve never looked into it so I don''t know what dll''s should be there.

[Edited by - kmsixpence on October 17, 2005 7:07:20 PM]

Share this post


Link to post
Share on other sites

If you use VC++, in your Project, set :

"Project Settings"/"Link"/"Object/Library Modules", add :
"d3dx8.lib"

You can then use any classes/functions/structs etc. defined in "d3dx8.h".

Regards,

Stoo.

Edited by - Stooby on February 22, 2002 12:11:33 AM

Share this post


Link to post
Share on other sites
... if I understand you correctly you thought the "dx8 developer runtime" would let you program for dx8, that sounds incorrect to me. From the name I would think the "dx8 developer runtime" is the debug version of the standard dx runtime that you install to play your games. The debug version might display special error messages etc.

To develop for dx8 you need to download the Dx8 SDK . It includes many .lib files (including d3dx8.lib) that you need to explicitly link into your project before building.

This is if I understand your question... it''s not very explicit as to what you were expecting or trying to do :o

When

Share this post


Link to post
Share on other sites
thanks!! i''m new, so i thought libs were only for importing from dlls. i can''t believe i got a response in 5 minutes. you guys rock! i guess i have to download the whole C++ SDK now...

Share this post


Link to post
Share on other sites
8... 8.1... only the newest is ever available I believe (in this case 8.1 of course)

actually I have both because I can't get vc5 to compile with 8.1 So I've just been doing all my work with 8.

Edited by - Sorrow on February 23, 2002 1:42:26 PM

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!