• Advertisement

Archived

This topic is now archived and is closed to further replies.

Download my first game!!

This topic is 5838 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! I just completed my pong game and my website. I'd be glad if you guys out there could try out the game in the demo section and tell me if it runs well on your PC. I've tried it on 5 PCs so far and one did not render well. Keep in mind this is my first game though, and that I'm half past all the beginner's reading (Nehe tuts and game programming book). Please send me comments if you see anything wrong in the game. And finally, you can also send me comments about my website. This is my first one and I hope you guys can tell me if there is big mistakes in it. http://geocities.com/kiroke2/ Thank you all! Kiroke Edited by - kiroke on February 23, 2002 12:54:48 AM

Share this post


Link to post
Share on other sites
Advertisement
Hmmm, didn''t work on my system (crashed)

System Specs:

Intel Pentium 3
Riva TNT 2 accelerator graphics card
256 MB RAM

Share this post


Link to post
Share on other sites
Here''s my specs:
* 266 MHz
* 128Mb RAM
* No 3D Video Card

Here''s the problems I had:
* Ran at about 1fps
* Controls didn''t respond
* The fire bitmap also had a twin in the lower-righthand
corner of my screen.

Here''s constructive advice on user-friendliness:
* Put the bitmaps in the data directory before you archive
it, so the player can just unzip it and play
* Might want to call it ''Kiroke''s Breakout'' as opposed to
''Kiroke''s Pong''

Otherwise, it looked like a well done game. Most people don''t ever bother to finish their first game. You''ve done more than most people ever do.

The Website is wonderful for a first website (Actually it''s pretty good for a 10th website) but you might want to worry about graphic size. (GIFs are a good way to go for things taht don''t use ''real life'' colors, like logos and such)

Share this post


Link to post
Share on other sites
Thx alot for your reply... I''ll change the game name:-) and I know it sounds crazy, but I''m really trying to archive the Data folder... well I''ll try harder it must be somthing in the options that I unchecked before.

About the game, well i dont really know what to optimize. I''ll look for a good software that could tell me where the program is spending all his time.

Kiroke

Share this post


Link to post
Share on other sites
I didn''t try the game, but I saw your web sight . The intro screen is way cool. How did you do that smearing effect?

--------------------------
Death from the shadows.

Share this post


Link to post
Share on other sites
The intro effect is from a tutorial i discovered 2 years ago... I only had the photoshop script I had made left. I really dont remember anything about the tutorial beside that it wasnt on a big photoshop website but rather on a private page.

Well the technique is pretty simple : you create your text, copy it in another layer, put motion blur on that layer vertically. Then you create another layer and apply the motion blur horizontally. You can also fade out the original text if you want your image to be less visible.

Kiroke

ps : it seems that i have exceeded my data transfer...that problem will be solved in about an hour :-)

Share this post


Link to post
Share on other sites
Hey neat game! one suggestion:
- speed up the paddle and the ball... its really quite slow!

And for those who complain about it crashing. You need to extract the game first then make sure the directory structure is right... I dont know but thats what i had todo.

Share this post


Link to post
Share on other sites
Would love to try it, but your geocities account has reached it maximum bandwidth... too bad. I''ll try again later.

--Buzzy

Share this post


Link to post
Share on other sites
I had the same problems as erissian...Kinda weird, i got:

350mhz
256mb of ram
windows2000 (if that matters)


actually, i have been having this problem alot. My demos, and openGL projects have been running slow...does anybody konw the problem i am having?


Share this post


Link to post
Share on other sites
I''ve rearanged the .zip file and it shouldn''t crash at startup anymore... Now I got a little problem : on SOME computers the text at the beginning stay while you play. This is not the effect I wanted so if you got an opinion on why it appears on some PCs and why it doesnt shows on others... just post a quick note here!

Thx

Kiroke

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
i didnt download the game but i looked at your portfolio and i was impressed. Can i just ask is there anything like that 3d studio max that i can download for free?

Share this post


Link to post
Share on other sites
Pretty good game
runned fine on my p3 933 128 ram
intel graphich controler ( i know it sux )
BUT ITS VERY SLOW !!
but good job

Share this post


Link to post
Share on other sites
Anonymous : I''ve heard of somthing called Milk Shape 3D you can look out at http://www.swissquake.ch/chumbalum-soft/index.html

I think its free :-)

Kiroke

Share this post


Link to post
Share on other sites
quote:
Original post by Anonymous Poster
i didnt download the game but i looked at your portfolio and i was impressed. Can i just ask is there anything like that 3d studio max that i can download for free?


3D Studio MAX is made by Discreet software. They also make a version of 3DS called GMax, and it''s free. Here''s a link:

http://www.discreet.com/products/gmax/

- Mike

Share this post


Link to post
Share on other sites
I had a slight problem running your game. It crashed right away. Keep trying, though. I'm almost certain it's my voodoo 5 5500 that's causing the problem, because the rest is Athlon "Classic" 800Mhz, 512MB PC100 SDRAM, Sound Blaster Live!, etc., etc.

I wish it would run, though. I like breakout! Oh, that's a damned good "first webpage", too.

EDIT: Oops, I almost forgot...Windows provided some "helpful" information for you:
PINGPONG caused an invalid page fault in
module 3DFXOGL.DLL at 015f:69079d9f.
Registers:
EAX=00000000 CS=015f EIP=69079d9f EFLGS=00010286
EBX=00550658 SS=0167 ESP=0067f244 EBP=0067f2a8
ECX=00000480 DS=0167 ESI=00000000 FS=869f
EDX=00450078 ES=0167 EDI=0067f2a8 GS=0000
Bytes at CS:EIP:
83 b8 88 08 00 00 01 75 0e b9 02 05 00 00 e8 be
Stack dump:
0067f25c 00402349 00000000 00000000 00000480 00000360 0067f308 00550670 00550658 cccccccc cccccccc cccccccc cccccccc cccccccc cccccccc cccccccc



Edited by - OOProgrammer on February 25, 2002 11:22:29 PM

Share this post


Link to post
Share on other sites
quote:
Original post by DarkHunter
actually, i have been having this problem alot. My demos, and openGL projects have been running slow...does anybody konw the problem i am having?



It might be old drivers... Maybe a driver update will do the trick? If you have old drivers the new OpenGL version may not be supported, resulting in exactly your problems. My brother had a Pentium III 800 Mhz with a GeForce 2 and 256 mb ram and he got less than half the framerates I got while my computer had only 1000 points on 3DMark benchmark and his got 3000!!! When he updated his drivers everything ran fine, or actually ULTRA FAST

It mattered so much because he has Windows XP, which did not include OpenGL driver compatibility... updating your video drivers really is a must there. You said you have another windows version, but it can still be the drivers if they are really old...



''Qui habet aures audiendi audiat'' - Me

A link to the website of my 3D engine will follow as soon as I have something concrete to show... Which will be soon.

Share this post


Link to post
Share on other sites
I''ve taken out the welcome text so the game should run alot faster now...

have fun!

Kiroke

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
hello, i''ve tried your demo, and i had some strange problems..

the whole screen flickered, and lots of parts of the frame buffer were kinda like in the wrong position (??) think this must be my video card (Quadro) ...

p.s.: the "you are dead" screen was ok everytime :-)

Share this post


Link to post
Share on other sites
It initialised, didn´t worked...
I have a Voodoo 3, pentium II 233Hz, 160Mg RAM. It was drawing something on the screen, I just can''t tell what it is. It looks as if the only some lines of the graphics were been drawed at the screen.
PS. Nice web page

Share this post


Link to post
Share on other sites
Interesting project

Runs extremely slow with alot of graphically glitches on my machine.

Amd 1.1ghz
512mb
WinXP
3dfx v5500

also...
on exit i went to a fullscreen w/ all white. needed to do a full reboot. i half expect my problems are from a hacked set of opengl drivers for my voodoo 5500 agp

Edited by - DaWookie on February 26, 2002 4:09:26 PM

Share this post


Link to post
Share on other sites

  • Advertisement