Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

adema

particle-engine tut

This topic is 5961 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

iv got 2 questions about about the 3rd game-programming tutorial: 1) if i set the color to (0.0f, 0.0f, 0.0f, 0.0f, 0.0f, 0.0f) the particles are shown red. shouldn''t they appear black? 2) in windowed mode the particle-engine looks fine but if i run it in fullscreen the particles look disturbed and the blending doesn''t work well. the graphics card shouldn''t be the problem because i tried it with 2 graphics cards and under win2k and winME. taking a higher resulution doesn''t help either.

Share this post


Link to post
Share on other sites
Advertisement
1) you CAN NOT set color to ( 0.0f, 0.0f, 0.0f, 0.0f, 0.0f, 0.0f). No color format has 6 components. you have something very wrong. And NO, they shouldn''t be black. they should be transparent (alpha=0)

2) this is probably related to 1)

There are more worlds than the one that you hold in your hand...

Share this post


Link to post
Share on other sites
1) the first 3 values are for the startcolor and the next 3 are for
the endcolor
2) the color is has nothing to to with the problem

Share this post


Link to post
Share on other sites
Do you have lighting enabled? Do you have texture binded? Do you have multitexturing enabled? Are you using VA? There are a bunh of other reasons that couse this error.

There are more worlds than the one that you hold in your hand...

Share this post


Link to post
Share on other sites
i use the code from the tuturial

but the stats are:

glPushAttrib(GL_DEPTH_BUFFER_BIT | GL_PIXEL_MODE_BIT);
glDisable(GL_DEPTH_TEST);
glBlendFunc(GL_SRC_ALPHA, GL_ONE);
glEnable(GL_BLEND);
glDisable(GL_LIGHTING);

and the texture is binded

Share this post


Link to post
Share on other sites
found the solution for the second problem:
in windowed mode the color-depth was set to 32bpp and
in fulscreen-mode it was set to 16bpp.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!