BJARNE STROUSSUP IS EVIL!!!

Started by
25 comments, last by Andrew Nguyen 22 years ago
I think it''s better that way. Less ambiguity. I''ve been doing some C# lately, and (probably because I don''t know the standard lib too well) I''m often found reading someone''s sample code, only to find out that what I originally thought to be an instance method was actually a static class member.

Not sure if the difference between . and -> is as significant, but I think :: is the right way.

"Eagles may soar, but weasels don''t get sucked into jet engines."
"There is only one everything"
Advertisement
You need . and -> because they are two different things.
quote:Original post by Buster
You need . and -> because they are two different things.

Interesting argument - we need smallpox and cholera because they are two different things.

--AnkhSVN - A Visual Studio .NET Addin for the Subversion version control system.[Project site] [IRC channel] [Blog]
quote:Original post by the Speed Bump
I''ve been doing some C# lately, and (probably because I don''t know the standard lib too well) I''m often found reading someone''s sample code, only to find out that what I originally thought to be an instance method was actually a static class member.

I dont really see that one - if you are following the recommended naming conventions it should look like this:

  MyClass.MyStaticMethod( arg1, arg2 );myInstanceObject.MyInstanceMethod( arg1, arg2 );  


--AnkhSVN - A Visual Studio .NET Addin for the Subversion version control system.[Project site] [IRC channel] [Blog]
Could a mod close this thread please? There''s not really a point to it, as there''s no problem that we or anyone else can help with.
Firstly, i cant believe all you people replied to this pointless thread, but more incredably, i cant believe i started reading it!!
Andrew if you have a problem with ''.'' and "->" and "::" then leave the programming world, and do something else eg picking cotton.

This topic is closed to new replies.

Advertisement