Archived

This topic is now archived and is closed to further replies.

jasonf

returning to single texturing from multitexturing....what am i missing?

Recommended Posts

OK, I check for multitexturing extentions, turn them on and multitexture away, but how the hell do I return to a non multitexture mode if I want to? Every time I go back to my software''s title graphic, I just see black...Do I have to stay in multitexture mode once its activated and keep writing to only ARB0? HELP!

Share this post


Link to post
Share on other sites
never do that
just disable the texture unit in question eg
glActiveTextureUnir(1)
disable(texture)
glActiveTextureUnir(0) make sure u set the unit to the one u want operated on

http://uk.geocities.com/sloppyturds/gotterdammerung.html

Share this post


Link to post
Share on other sites
just to clarify, you NEVER enable or disable multitexturing. its simply ALWAYS ENABLED if your gpu supports it.. all you need is to disable/enable the different texturestages (2 on most, 3 on older radeons, 6 on the new radeon, 4 on geforce3 and 4), as he told you

glActiveTextureARB(GL_TEXTURE1_ARB);
glDisable(GL_TEXTURE_2D);

that disables the second texture => you will only use the first and the second one is simply discarted..

Share this post


Link to post
Share on other sites