Archived

This topic is now archived and is closed to further replies.

Can't see GLUT Stroke Characters :P

This topic is 5753 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Okay.. This is driving me batty, cause it should work. I''ve got a method to simply get passed a GLUT stroke font, and a char* array... and it WORKS.. but I don''t SEE the text Here is the method:
  
void AppPolygon::drawStrokeString(void* font, char* text)
{
	glPushMatrix();		

		glLoadIdentity();
		int length = strlen(text);
		
		glColor3f(0.7, 0.2, 0.1);

		for(int counter = 0; counter < length; ++counter)
		{			
			glutStrokeCharacter(font, text[counter]);
		}

	glPopMatrix();
}
  
The viewport is 10 x 10. This should, in theory, display the text at 0,0.. but I see nothing. I''ve tried translating it all over the place, scaling it.. nothing.. I''m totally stuck! (and yes, the method actually runs, checked that too) and the text colour is different from the background. I''ve done a similar thing with bitmap chars, and had no issue. Any help would be appreciated. Mark

Share this post


Link to post
Share on other sites
Forget it..

I just had to scale the text down.. found out when I did a overall scale function on the entire screen.

Silly me.

Neurotic

----
Vector7 Software Engineering
www.vector7.com.au
----

Share this post


Link to post
Share on other sites