Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

JonnyBoy

Have I set the 'draw my stuff slow' flag or something ?

This topic is 5939 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have been having performance issues with my app (Framework based). So I took the Optimized Mesh example and rendered an object 200 times per frame. This achieved a frame rate of 612fps. I then did exactly the same with my app, and could only get 293 fps. The render code is literally just DrawSubset. Texture changes have been commented out on both apps. The weird thing is, if I comment out the DrawSubset calls, then my app achieves a faster frame rate. I have done the following before the render... gm_pd3dDevice->SetRenderState(D3DRS_LIGHTING,FALSE); gm_pd3dDevice->SetRenderState(D3DRS_ALPHABLENDENABLE,FALSE); m_pd3dDevice->SetTexture(0,NULL); Can anyone think of anything else that could halve the rendering speed ? Both are running with PURE HW VP. [edited by - Jonnyboy on April 17, 2002 12:41:22 PM]

Share this post


Link to post
Share on other sites
Advertisement
Are you using the OptimizeInPlace() function in your code? The optimize mesh sample optimizes the mesh with this function which will increase the frame rate significantly.

Ryan

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!