Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

unknownfriend

Particle Problem

This topic is 6026 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When ever I veiw a demo, the particles in the demo have a grey tranlucent square around them. I never had this problem before. I am pretty sure that my video card and driver is good enough because this is the first time in 2 years this happened. What can I do to fix this?

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
Little girl sees her mom taking a bath. Little girl asks: What is that? Mom says: That is a vagina. Little girl asks: When will I get one of those? Mom says: When you grow up. Little girl sees her dad come out of the shower. Little girl asks: What is that? Dad replies: That is a penis. Little girl asks: when will I get one of those? Dad replies: As soon as your mom goes to work.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Tisk tisk, is it just me, or do we have some sick minded kids (I sure hope they are kids.) around here lately. . . ?

Share this post


Link to post
Share on other sites
NeHe_Lover or any moderator here, can''t you delete that stupid ''joke'' ? damn sick people. Gamedev should have an option to filter ''bad'' words, that would help sometimes.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
I was pretty happy when I saw all those posts. Then I saw that very disturbing joke and now I am very pissed off. God damn why you put that there anyway?

Share this post


Link to post
Share on other sites
Hmm...Anonymous Poster do you enjoy talking to yourself? I guess if you like unintelligent conversation

...

anyway.

Those translucent squares are the particles. In particle engines, particles a particle texture is put onto a square. The reason you dont see a square is because the edge of the particle is defined by the texture (the rest is removed using alpha channel).

What may have happened is that you might have changed your color config on your system and now you can see the squares. Its really nothing big because you find a little variance between system colors while running the same application. In other words the squares show up some of the time depending on the system.

The problem I have with particle systems now is having them depth sort with the rest of my objects. Im probably going to switch to a particle api.

Hope that helps.

Ancient Wisdom:
"Copy and paste fills the page, coding fills the mind...and the debugger."

Share this post


Link to post
Share on other sites
If you have compiled the demo yourself and changed it in anyway, you may have to make sure that depth testing is disabled before drawing the particles. If it is the same for all particle effects, even on programs you haven''t written/compiled yourself then the answer is probably what the last guy said

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!