Archived

This topic is now archived and is closed to further replies.

DirectPlay "Unresolved External Symbol" Errors

This topic is 5701 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am having a problem compiling as I am getting this: ......... Linking... SimplePeer.obj : error LNK2001: unresolved external symbol _CLSID_DirectPlay8LobbiedApplication SimplePeer.obj : error LNK2001: unresolved external symbol _IID_IDirectPlay8LobbiedApplication SimplePeer.obj : error LNK2001: unresolved external symbol _CLSID_DirectPlay8Peer SimplePeer.obj : error LNK2001: unresolved external symbol _IID_IDirectPlay8Peer NetConnect.obj : error LNK2001: unresolved external symbol _CLSID_DirectPlay8Address NetConnect.obj : error LNK2001: unresolved external symbol _IID_IDirectPlay8Address Win32_Debug_Unicode/simplepeer.exe : fatal error LNK1120: 6 unresolved externals Error executing link.exe. simplepeer.exe - 7 error(s), 0 warning(s) ................. The thing is, I can''t even compile the DirectPlay sample programs because of this error, so its not my code. What is going on??? Thanks. *====================* http://www.syntasoft.com *=======================*

Share this post


Link to post
Share on other sites
either you dont have the include directories set up correctly, directplay8 is not installed correctly, or the include files are simply missing from the ms example (hey, it happens.) check if its linked with dxguid.lib

Share this post


Link to post
Share on other sites
One other thing though. I got it working, but I am having a problem with the Initialize(); For some reason, my program bombs when I call that function. Why? I am following the step-by-step instructions of the DirectX documentation. Please help.

Share this post


Link to post
Share on other sites