Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Darkeye

TGA/Transparency Problems

This topic is 5897 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey, I''m in serious need of some help here, I''m going insane trying to solve this. Bascially I am trying to draw a 32 bit TGA with the transparent bits missing. I made a tga with a transparent background using GIMP, and load it using NeHe''s TGA loading code, but when I draw it onscreen, it just draws the transparent sections black. I don''t know if there is a problem with the .tga file, or I am using the wrong blendfunc. If anyone could send me a .tga file that they can confirm works properly with transparency in it, or if someone could tell me what blendfunc I should be using, I would be most greatful. My email address to send the file to is darkeye@exile.asylumnet.org Thanks a lot.

Share this post


Link to post
Share on other sites
Advertisement
OK but the TGA must have a "alpha channel" for correctly working.

========================
Leyder Dylan
http://ibelgique.ifrance.com/Slug-Production/

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!