Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

AfroFire

Dev-C++: Problem Compiling

This topic is 5982 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Alright, I can''t figure this out. I''m trying to compile an SDL application in Dev-C++ and I keep getting this: "[Linker error] undefined reference to `WinMain@16''" Why?! I''ve created it under a Win App, and a Console app, but still I get the error. I''m running Windows XP. I feel like I''m forgetting something . . . Any help appreciated. Thanks. -AfroFire

Share this post


Link to post
Share on other sites
Advertisement
Did you set up the libraries and includes properly?

Go here for info on setting it up with Dev-C++ 4.01.

If you are using Dev-C++ 5 (4.9.x) go here and download the SDL package. It automatically sets everything up and gives you a nice template.

Enjoy.

- Deeek

Share this post


Link to post
Share on other sites
Most times you create a Win32 application, your application entry point is WinMain, not main. Under MSVC, Console Applications have an entry point of main, but Dev-C++ may behave differentl. Consult your documentation both fr the appropriate application entry point as well as the parameter list and return type for WinMain.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!