Archived

This topic is now archived and is closed to further replies.

DX 8.0 ->8.1 : Troubles anyone?

This topic is 5672 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello. I''ve passed to 8.1 runtime+sdk, and i''ve encountered many problems. Premise: i''ve got a brand new pc and an old one, and i''ts the same, so it''s not the machine. -i import from 3ds files, store into a Vertex Buffer, render it: on 8.1 sometimes you don''t see SOME objects. others are corrupted. -strange light behaviour on complex surfaces. -z buffer looks less precise: thing appear behind some others,... WHY?? Is there something to do? I tested very little, but i see that the 3ds->.X converter is STLL buggy. Oh, no. BYe. (let me know!)

Share this post


Link to post
Share on other sites
I''m in with you on his one(Sorry, no solutions here)...Once i had installed dx 8.1 my program actually gave me compilation errors!

( I know this is off the topic but some of my DivX movies with MPEG Layer 3 Audio Codecs won''t play, either! )

Well...I don''t know about the .X files thingy. I imported MD3 (Quake3) character models w/ animations and stuff. Works fine...
Out of curiousity: What video card do you have?
-idx

to code or not to code, that is the algorithm

Share this post


Link to post
Share on other sites
One thing I had a problem with is that 32 bit indices compiled under 8, but did not work under 8.1 (since my geforce 2 doesn''t actually support them). Just changing the indices to 16 bit solved this problem.

Share this post


Link to post
Share on other sites