Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Lazy303

Problem with DPlay

This topic is 6036 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi! I just can''t get GetClientInfo() to work! it allways returns some unknown error. When i join the server i do this from the client ZeroMemory( &dpPlayerInfo, sizeof(DPN_PLAYER_INFO) ); dpPlayerInfo.dwSize = sizeof(DPN_PLAYER_INFO); dpPlayerInfo.dwInfoFlags = DPNINFO_NAME; dpPlayerInfo.pwszName = wszClientName; dpPlayerInfo.dwDataSize=0; dpPlayerInfo.pvData=NULL; if( FAILED( hr = m_pDPClient->SetClientInf(&dpPlayerInfo, NULL, NULL, DPNSETCLIENTINFO_SYNC ) ) ) { return E_FAIL; } and then from the server i do DWORD dwSize=sizeof(DPN_PLAYER_INFO); DWORD dwFlags=DPNINFO_NAME; DPN_PLAYER_INFO pi; pi.dwSize=sizeof(DPN_PLAYER_INFO); pi.dwDataSize=0; pi.dwInfoFlags=DPNPLAYER_LOCAL; HRESULT hr=m_pDPServer->GetClientInfo(dpnid,&pi,&dwSize,dwFlags); Maybe I can''t call GetClientInfo from the DP thread? hmm... Anyone got a clue?

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!