Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Nukem

Line ThickNess

This topic is 5890 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I used glLineWidth to change the thinkness of a line i drew. But that also changes all the other lines to the same thinkness on the screen. I en/disabled GL_LINE_SMOOTH but it still happens. Is there a way I can make it so the thinkness will only change for that one line and not everything? thx nuke

Share this post


Link to post
Share on other sites
Advertisement
You could always just change it back to one when you are done drawing your line

Share this post


Link to post
Share on other sites
Yeah.. you have to remember that OpenGL is a state-thingy (one of those american country-type things) *grin*

lol.. but you know what I mean :D. So if during one rendering frame you change the line width up, it will stay up until it''s brought down again. So just do this.

increase line width.
draw line.
decrease line width.

Note: this is something to remember for later, as soon as you get into using multitexturing e.t.c you''ll need to make sure you know this hehe, or you''ll find you run into problems

Share this post


Link to post
Share on other sites
thx It just seems that everything else had its own enable and disable so I thought this would to.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!