Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Laroche

Weird direct audio problem

This topic is 5890 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When i run my app without daudio activated, everything works fine..when i try and get daudio (directMusic8, specifically) to work, all i get is a "thunk" from my speakers, and instead of pressing escape once to exit, i have to press twice..anyone know the reason why?

Share this post


Link to post
Share on other sites
Advertisement
I''m not quite sure what you mean exactly, and how to check for it. Could you be a little more descriptive, please?

Share this post


Link to post
Share on other sites
noone knows what''s wrong? or should i send in more info? I''d really appreciate the help if anyone could.

Share this post


Link to post
Share on other sites
I''m just wondering if when you assign the pointers during the initialization of the sound system, they are somehow getting confused with some other pointer in your code, or aren''t being set properly.

The fact that you have to hit Esc twice to exit make me suspect something. But at this point I can only guess. Typically the sound system doesn''t involve itself at all with keystrokes. Your routine that handles the Esc key could also be affected when your sound system is initialized, if your logic isn''t right.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!