Archived

This topic is now archived and is closed to further replies.

chbfiv

cd /mnt/cdrom :bash: i/o error

Recommended Posts

root>cd /mnt/cdrom ide-scsi:hda: unsupported cmd in request queue (0) isofs_read_super: bread failed, dev=03:00,iso_blknum=16, block=32 bash: cd:mnt/cdrom: Input/Output error I cant even mount my cdrom to load my geforce drivers to run in Xwindows. Any ideas? Im rather lost on how to fix an i/o error on my cdrom other then, well nothing! I tryed remounting, because it mounted it on startup and nothing...I hope someone knows

Share this post


Link to post
Share on other sites
I''ve really been hacking away at this...So far it still has the same error.

I was reading online and in a book how the location /hdx changes based on what IDE M/S 1/2 . It told me to symlink(symboliclink I guess) the /dev/hdx to /mnt/cdrom then remount it.
So, I have no clue if its hda,hdb,hdc,hdd, but its one of them, so I do this one at a time
ln -s /dev/hda /mnt/cdrom
no errors
then I try and mount the cdrom
mount -t iso9600 /dev/cdrom /mnt/cdrom
and it says incorrect fs type(iso9660) though I thought that was right, based on all my sources.
so I try the basic way
mount /mnt/cdrom
still the same error, I do this for all the locations /hda-/hdd.

It told me I can find out what the location is of the cdrom if I use dmesg, but it only showed an error log and I did not see any options(at least that I could tell) that would do it.
I understand alot of whats going on, I dont understand why none of it is working. I follow strick instructions and it still leads me to errors.

Someone must know!=) why am I smiling after all this, bah!

Share this post


Link to post
Share on other sites
ln -s /dev/hda /mnt/cdrom
I don''t know why you''d do that. /mnt/cdrom should be its own directory. So, to fix this:
rm /mnt/cdrom; mkdir /mnt/cdrom
It probably told you to do something like this:
ln -s /dev/hda /dev/cdrom
Where hda is replaced with the correct device. And then you could do something like this:
mount -t iso9660 /dev/cdrom /mnt/cdrom
To mount the cdrom. I don''t know which device your CD-ROM drive is, so you''ll have to figure that out on your own.

Share this post


Link to post
Share on other sites
I just kept at it, seems that for alot of people the CDROM even though its not a SCSI is stored in /dev/scd0
I just went down the list od IDE and SCSI and found it.
Now I find out i need to install a new kernal,4.01 of Xfree86 and 3.0.4 of rpm to even rpm the NVIDIA drivers. Suck, but at least im getting somewhere.
Also if you got a sec, whats the command to save and to exit vi?
I used it to edit my /etc/fstab but I didnt find the save nor the exit command on the Manual , I just used ctrl-f4 to logon a user, which im sure is not good after a while without logging out

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
quote:
Original post by chbfiv
I just kept at it, seems that for alot of people the CDROM even though its not a SCSI is stored in /dev/scd0


An IDE CD-ROM will appear as a SCSI device if your kernel has the Emulate SCSI option enabled for IDE CD-ROMs. If this is disabled the CD-ROM will appear as a normal IDE device (i.e. /dev/hd?).
quote:
I just used ctrl-f4 to logon a user, which im sure is not good after a while without logging out

Using CTRL-F? to switch pseudo-terminal and login multiple times is fine.

Share this post


Link to post
Share on other sites