Jump to content
  • Advertisement

alexbt

Member
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

100 Neutral

About alexbt

  • Rank
    Newbie
  1. I have included in my project old DXUTsound.h and DXUTsound.cpp files and all dependences .h and .cpp files. What I did is I have updated DirectxSDK, then I have included DXUT map to my project, and instead of DXUTsound files I have included SDKwavefile files, in a linker->input->additional dependencies I have added winmm.lib, now everything works fine.
  2. I have added all the .cpp files which are needed, and after compiling this I got the same error as in this thread: http://www.gamedev.net/community/forums/topic.asp?topic_id=331420 I tried to find solution with google, I found nothing helpful. [Edited by - alexbt on July 10, 2010 6:00:07 AM]
  3. According MSDN Help and other tutorials to open a *.wav file I'm using the following code source: CWaveFile *waveFile = new CWaveFile(); HRESULT hr = waveFile->Open(L"sound1.wav",NULL, WAVEFILE_READ); if(FAILED(hr)) { MessageBox(hWnd, "Can NOT open the wave file!","Message",MB_OK); } but when I compile above code, I get this errors: 1>main.obj : error LNK2019: unresolved external symbol "public: long __thiscall CWaveFile::Open(wchar_t *,struct tWAVEFORMATEX *,unsigned long)" (?Open@CWaveFile@@QAEJPA_WPAUtWAVEFORMATEX@@K@Z) referenced in function "void __cdecl loadSound(void)" (?loadSound@@YAXXZ) 1>main.obj : error LNK2019: unresolved external symbol "public: __thiscall CWaveFile::CWaveFile(void)" (??0CWaveFile@@QAE@XZ) referenced in function "void __cdecl loadSound(void)" (?loadSound@@YAXXZ) Can anyone help me, what I do wrong?
  4. I just changed testSprite.matWorld = (matTranslation*matScalation) to testSprite.matWorld = (matScalation*matTranslation) and sprite has appeared on the screen. Thanks a lot.
  5. I have checked everything what is possible with FAILED macro in whole code, didn't find something wrong. Earlier I have tried this source code: http://www.dx11.org.uk/book2.zip and this code works, my code doesn't work. I have compared every line from this code with my code source, practical they are the same. [Edited by - alexbt on June 10, 2010 11:29:17 PM]
  6. Gage64 Thanks for advice.
  7. I'm new in Directx programming so I tried to draw a sprite in DirectX 10, but it won't work. I spent lot of time to find out what is wrong. Please help me!!! Here is my code source: http://pastebin.ca/1879018 [Edited by - alexbt on June 8, 2010 7:23:06 AM]
  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!