xzbobzx

Member
  • Content count

    13
  • Joined

  • Last visited

Community Reputation

120 Neutral

About xzbobzx

  • Rank
    Member
  1. Trouble with 2D speed vectoring.

    [quote name='Álvaro' timestamp='1352397825' post='4998950'] I think this is all you need: [code]double const pi = atan(1.0)*4.0; double const degrees = pi/180.0; Velocity_X = -Speed * sin(Rotation * degrees); Velocity_Y = Speed * cos(Rotation * degrees);[/code] You need to make sure your angles are in radians before you pass them to cos() or sin(). [/quote] That works great! Thanks man, massive kudos.
  2. So I'm working on a 2D, top-down racer-ish game and I devised an interesting algorithm using cosines and angles to calculate the speed vector. Too bad for me, it doesn't work like it's supposed to. [CODE] if( Rotation > 0 && Rotation < 90 ) { float Section_A = Speed*cos(90-Rotation); Velocity_Y = Speed*cos(Rotation); Velocity_X = Section_A - Section_A - Section_A; } else if( Rotation > 90 && Rotation < 180) { float Section_B = Speed*cos(180-Rotation); float Section_C = Speed*cos(Rotation-90); Velocity_Y = Section_B - Section_B - Section_B; Velocity_X = Section_C - Section_C - Section_C; } else if( Rotation > 180 && Rotation < 270) { float Section_D = Speed*cos(Rotation-180); Velocity_Y = Section_D - Section_D - Section_D; Velocity_X = Speed*cos(270-Rotation); } else if( Rotation > 270 && Rotation < 360) { Velocity_Y = Speed*cos(360-Rotation); Velocity_X = Speed*cos(Rotation-270); } else if( Rotation < 1 ) { Velocity_Y = Speed; Velocity_X = 0; } else if( Rotation > 89 && Rotation < 91 ) { Velocity_Y = 0; Velocity_X = Speed - Speed - Speed; } else if( Rotation > 179 && Rotation < 181 ) { Velocity_Y = Speed - Speed - Speed; Velocity_X = 0; } else if( Rotation > 269 && Rotation < 271 ) { Velocity_Y = 0; Velocity_X = Speed; } Position_Y = Position_Y + Velocity_Y; Position_X = Position_X + Velocity_X; [/CODE] (0 rotation means the car is facing down, 90 it's facing left, 180 up, 270 right. At >359 rotation goes insta 0.) All that this does, is spaz out. In my theory it should work, but apparently it does not. Can anyone help?
  3. A spam a day keeps the inactiveness away.
  4. Lol, advertising groups works. :o
  5. [quote name='fastcall22' timestamp='1304441195' post='4806013'] By default, when you run your program from within the IDE, the working directory is set to "$(ProjectDir)", which is the directory containing the project file and source files. However, if you were to run your program from outside the IDE, then the working directory is the directory of the executable. You can change the working directory of a program by going to the project properties (alt+f7), and changing the "Working Directory" field under "Debugging->General". [/quote] Ah, ok, so it should work if I placed the 'hello.bmp' in the folder containing the .exe? Edit: it worked.
  6. I also get this sometimes: LINK : [external drive]\SDL_Tutorial\Debug\SDL_Tutorial.exe not found or not built by the last incremental link; performing full link [external drive] being, of course, my external drive. :|
  7. Also didn't work... :|
  8. Tried all other options, doesn't do anything... :c
  9. I clicked the properties on hello.bmp, and it said; Item Type: Does not participate in build
  10. SDL_LoadBMP failed: Couldn't open hello.bmp That's what I got in stdout.
  11. I guess I'll go over the setting up part once more.
  12. Its there and in the right path, but It still doesn't work. :c
  13. So I tried lesson 1, all compiles fine. But when I run the program it's just a black screen without any picture on it, what have I done wrong?
  14. Spiderwebs make you go REALLY slow on minecraft.... :<