pankajsachdeva85

Members
  • Content count

    7
  • Joined

  • Last visited

Community Reputation

100 Neutral

About pankajsachdeva85

  • Rank
    Newbie
  1. Hi, I am working on an application which draw a textured quad and has the capability of zoom and pan the view. The application is developed using Direct3D 9 API through SlimDX. Till now I have not set any of the States like RenderState, SampleState, and TextureStageState. Just I disabling the depth buffer. I have attached the images that shows how the textured quad looks before and after the rubberband window is used on it to zoom. I have tried many different combination of states but I couldn't figure out what is going wrong here. So, if you guys please help me in fixing the bug, I'll be great full to you. Thank You, Pankaj
  2. Hi, I am working on an application which draw a textured quad and has the capability of zoom and pan the view. The application is developed using Direct3D 9 API through SlimDX. Till now I have not set any of the States like RenderState, SampleState, and TextureStageState. Just I disabling the depth buffer.
  3. Shaders are never available for debug

    Thank you all I figured out why I wasn't able to debug the shaders. I was using the optimus graphics card and because of which I wasn't able to debug the shaders.
  4. Hi, I am trying to render text using in the MiniTri11 sample application that comes with SlimDX SDK. I am using the SpriteRenderer & SpriteFront (that can generate a sprite sheet of glyphs using GDI+) class as implemented [url="http://dx11experiments.codeplex.com/"]this[/url] project. But some how I am unable to identify why text does not show up on screen. I have attached the sample that I have prepared, with this post. If, anyone of you guys could help me in doing it, I'll be highly thankful. Thank You, Pankaj
  5. Shaders are never available for debug

    [quote name='MJP' timestamp='1330675141' post='4918517'] The docs say that you have to be using a remote debugging session to run the shader debugger. [/quote] Yes, I have set up the remote debugging session. In those settings I have set the Remote Command as the executable path on my machine and set the Remote Server Name as my computer's name but no success there. Still I see the "[b]Shader Debugger is not available[/b]" in shader list. Thanks, Pankaj
  6. Shaders are never available for debug

    Hi Niko Suni, Is it necessary to have two separate computers (workstations) or we can do the debugging with a single computer with two graphics cards? BTW, I have a laptop. What would you recommend for the best setup for game development? Thank You, Pankaj
  7. [size=4]Hi,[/size] [size=4]I am trying to debug the shaders using the NVIDIA Parallel Nsight 2.1 but I am unable to do so. As soon as I start debug with Nsight there is a message in Shaders window "[b]Shader Debugger is not available[/b]". So, I googled this problem and found this [url="http://forums.nvidia.com/index.php?showtopic=205548"]link[/url]. I have tried all the options that are discussed into the above thread, still no success.[/size] [size=4]If any of you guys have any experience of debugging shaders, then please help me with this problem.[/size] [size=4]Thanks,[/size] [size=4]Pankaj[/size]