nyl2000

Members
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

129 Neutral

About nyl2000

  • Rank
    Newbie
  1. I am currently trying to draw a plane texture in openGL from a loaded BMP file. Only I don't know the exact codes to do this. I understand that getBMPData(), glBindTexture(), and glTexImage() are some of the functions I need, but I could use an example to understand how to use them.
  2. Codeblocks Setup with SDL

    I just tried -lSDL_main, it doesnt work either; plus I remember -lSDLmain working from before I reformatted.
  3. Codeblocks Setup with SDL

    I am trying to setup Code::Blocks to use SDL. I have all the libraries setup per this tutorial. [url="http://lazyfoo.net/SDL_tutorials/lesson01/windows/codeblocks/index.php"]http://lazyfoo.net/S...ocks/index.php[/url] I am currently getting this error: File ld.exe cannot find -lSDLmain I know the code works; I have had my comp reformatted recently, and have taken the code from a backup. I believe that there is a step that I have forgotten in reinstalling Code::Blocks and SDL. Can anyone explain to me what this error is exactly, so I have a better idea of what to look for?
  4. I am currently starting out with event handling systems in SDL/C++. I have followed a tutorial to create a simple program that should quit the program when the user X's out/Closes the window. The program compiles and works as intended, except that the close button does not respond at all when it is clicked. The program stays in its while loop forever, without receiving the command to quit. I am using a Windows7 Computer, with Codeblocks IDE. Attached is the program, I am not sure what is preventing me from closing the window at all.
  5. Thank you, DarkHorseKnight, May I ask what #undef main is exactly?
  6. I have just gotten started with trying to use SDL/OpenGL for C++. I have followed several tutorials, and have gotten the example programs to compile without error. However, when I try to run the program, a blank window shows up (instead of the intended image of the tutorial). If I remove the SDL_Delay, the blank window also appears to be unresponsive. Also, [left]any cin and cout I/O that I add don't seem to show up on the window (cout writes on a txt file and cin does not? wait for keyboard input before moving on in the program)[/background][/left] I am using a windows 7 64 bit machine, and have attempted the tutorial on both Codeblocks and Visual Studio 2010 with the same problematic result. I have already tried adjusting for the 32-bit compatibility problem by using WOW64, it seems to have no effect. This is the tutorial. [url="http://lazyfoo.net/SDL_tutorials/lesson01/index.php"]http://lazyfoo.net/S...son01/index.php[/url] The full tutorial source code is also attached. I hope someone can at least tell me what the problem is exactly.