Jump to content
  • Advertisement

JotDot

Member
  • Content Count

    64
  • Joined

  • Last visited

Community Reputation

146 Neutral

About JotDot

  • Rank
    Member
  1. glIsTexture needs the texture ID - not the address of it. ie: "So I add glIsTexture(&texName[id]) right after this code..." should be glIsTexture(texName[id]) source: opengl.org: http://www.opengl.org/sdk/docs/man/xhtml/glIsTexture.xml
  2. JotDot

    Normals all equal to 0?

    I can see two potential problems. First, both x and z start at zero and go up. You immediately establish a terrain[] value for [x+z*MAP_X] but in the CalculateNormal call you reference terrain[] elements x+1 and z+1. Those values haven't been established yet. Also, there could be a potential access past array bounds since your x goes up to MAP_X-1 and z goes up to MAP_Z-1 but you are accessing x+1 and z+1. I see how you need those extra set of points but make sure storage is allocated for it and they too get initialized.
  3. JotDot

    DirectSound sucks?

    Here is a good doc explaining the confusion about 6db vs 3db: clicky In summary: Taking a single sound and making it twice as loud is 6db where combining two different sounds of the same level results in an increase of 3db. It has to do with the two sounds being similar enough (i.e., phase correlated). Thus "twice as loud" is between 3db to 6db depending on the similarity of the two sounds. Since we are talking about adjusting the volume of one sound, I'd assume 6db is the value to use here. You will find a summary of the general rules about half way down that page.
  4. JotDot

    Opengl app for testing

    The view drifts slowly up and to the left. With VSync on, I can control the view with the mouse. It is hard to explain what happens but it is plain horrible. I have to move the mouse real slowly (even then it is jerky) or else it seems to decide to turn at some predetermined rate and then suddenly stop. This rate seems to depend on how fast I move the mouse. With VSync off, the mouse hardly has any effect at all - I have to constantly move the mouse down and to the right (over and over continuously) to counter the drift. The arrow keys work properly. Framerate: 1139 fps P4 3.0Ghz 6800GT 256Meg WinXP SP2
  5. JotDot

    Test my app please

    FPS at start position: 224 Context Switching: about 0.25 P4 3.0 Ghz 6800GT 256 Meg Log File: 15:13:12 - LOG CREATED AT 23/11/2004 15:13:12 - Total memory usage: 0 bytes of 0 15:13:13 -----Starting Direct Sound----- 15:13:13 - Direct Sound device created 15:13:13 - Primary buffer created 15:13:13 - Allocating quadtree structure - depth = 5 15:13:13 - Creating scene quadtree 15:13:13 - Quadtree creating done, time = 0.455 ms 15:13:13 - Texture normalization loaded 15:13:13 - Standard Codepath Supported 15:13:13 - Vertex Shader sh/GLSL/parallax.vert compiled 15:13:13 - Fragment Shader sh/GLSL/parallax.frag compiled 15:13:13 - Vertex Shader sh/GLSL/infinite.vert compiled 15:13:13 - Fragment Shader sh/GLSL/infinite.frag compiled 15:13:13 - GLSL Codepath supported 15:13:13 - NV20 Codepath Supported 15:13:13 ! R200 Codepath requires at least 6 texture units 15:13:13 ! R200 Codepath not supported 15:13:13 - Vertex Shader sh/GLSL/glow.vert compiled 15:13:13 - Fragment Shader sh/GLSL/glow.frag compiled 15:13:14 - Vertex Shader sh/GLSL/water.vert compiled 15:13:14 - Fragment Shader sh/GLSL/water.frag compiled 15:13:14 - Texture texturas/skybox loaded 15:13:14 - Texture texturas/particula.dds loaded 15:13:14 - Texture texturas/particula1.dds loaded 15:13:14 - Texture texturas/particula2.dds loaded 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 ! Unable to load the texture texturas/particula3.dds 15:13:14 - Texture texturas/sky1.dds loaded 15:13:14 ! Unable to load the texture texturas/mapa512.map0.bmp 15:13:14 - Texture texturas/mapa512.map0.dds loaded 15:13:14 ! Unable to load the texture texturas/mapa512.map1.bmp 15:13:14 - Texture texturas/mapa512.map1.dds loaded 15:13:14 ! Unable to load the texture texturas/mapa512.map2.bmp 15:13:14 - Texture texturas/mapa512.map2.dds loaded 15:13:14 ! Unable to load the texture texturas/mapa512.map3.bmp 15:13:14 - Texture texturas/mapa512.map3.dds loaded 15:13:14 - Texture texturas/detalhe1.dds loaded 15:13:14 - Map file mapas/mapa512.map loaded 15:13:14 - Texture texturas/water_bump.dds loaded 15:13:14 - Texture texturas/water.dds loaded 15:13:14 - Texture texturas/black.dds loaded 15:13:14 - Texture texturas\CANO.DDS loaded 15:13:14 - Texture texturas\CANO_bump.DDS loaded 15:13:14 - Mesh modelos\cano.col created 15:13:14 - Mesh instance created 15:13:14 - Creating mesh instance for modelos\cano.col - 15:13:14 - Mesh instance created 15:13:14 - Texture texturas\chao_1.dds loaded 15:13:14 - Texture texturas\chao_1_bump.dds loaded 15:13:14 - Mesh modelos\caixa.col created 15:13:14 - Mesh instance created 15:13:14 - Mesh modelos\box.col created 15:13:14 - Mesh instance created 15:13:14 - Creating mesh instance for modelos\caixa.col - 15:13:14 - Mesh instance created 15:13:14 - Creating mesh instance for modelos\box.col - 15:13:14 - Mesh instance created 15:13:14 - Path modelos\path_luz_teste1.pth loaded 15:13:14 - Level teste/teste.lvl loaded 15:14:16 - Aplicativo finalizado 15:14:16 - Total memory usage: 15335948 bytes of 50000000 15:14:16 - LOG FINALIZATED
  6. The biggest annoyance was when I had a few umm thingies occupying/overlapping one cell. I wanted to click on a base but it kept selecting the same whatchamacallit. Would be nice when this is the case - repeated clicks would cycle thru each one inside/overlapping the cell. This way I would not have to disperse everything just to get at the one I wanted in the first place. Rarely (but it happened a few times) the program craps out with umm "Severe Error" (?) when I launched a Battle round. Something more descriptive would be nice (at least for your debugging needs). There were a couple other things but I'll post them once I figure out for sure if it is a "bug" or just sloppy mouse clicking on my part. The bases seem to be quite invunerable. I can win the game just by putting out enough posters at the beginning to trap as much area as I can. (6 to 8 usually does it.) I then stock up enough points to build a drain base and protect it with an implosion drone. Then I build a turret base + implosion drone. After that, all I need to do is to get energy by tricking the enemies to attack a low grade hacker (so I can drain the opponents). This allows me to flood the area with my own advanced hackers and keep draining the enemy by relocating my drain base. I don't use any wreckers at all. I don't like the Arena mode. Compared to the Battle mode, it seems rather primative in design. If you were to keep it, I would suggest improving it in some way. Although this post might sound negative - this is a really neat game. Keep up the good work!
  7. Version 5 works 6 crashes like before. I still can get 5 to crash when I click back and forth different windows. Number 6 works with task manager on top as the previous ones did. As a side note - your original version works if I have task manager opened on top of it. Strangeness. Seems like it works ok when it opens under a window but not if it opens on top (of another window or just simply on the desktop). I set MSN Messenger to "always on top" and that has the same effect as task manager. Good luck. I will check occasionally to see if you still are interested in continuing this at a later date - or even email me. PS: If anyone else trys the app and posts any stats - please include the driver version for the video card. I'm wondering if that could be part of the problem?
  8. debug1 works: Black window. Can change focus without crashes but didn't spend much time doing that. debug2 works: dark grey rect. The little green rects looks like it gets covered up at a set rate so I am assuming it is the rotating torus (which I can't see). Oh - debug2 crashes occasionally while changing focus. debug3 looks like debug2 except dimmer. Can get it to crash too. debug4 crashes upon startup. Give up if I get bored with it?? It is just getting interesting!! (/me grins) Get a load of this: debug3 and debug4 *work* if I open up task manager so that it overlaps the rendering window *before* I start up those two versions. I can change focus, even drag the task manager window around... just as long as I don't fully drag the task manager off the window. It's getting interesting... Edit: When the task manager leaves the client portion of the window. I dragged it slowly just now and observed that it crashes at that point but the task manager window is still over the non-client frame. I'll let you know anything else I can find that might help.
  9. Ok. Uniformly lit grey rect with a lit, rotating torus inside it - lit just like your pic except the whole image is b/w without shadows. Btw: If I change focus to another window - it crashes too. I can shut it down properly if I don't change focus from that window.
  10. Email with log output sent to your address in your profile
  11. Well, scatter n/0 prints to your log file inside your debug code and give me a link for that. I can run it and even email you a zipped file of the output (might be large). That may help. Would be nice if I could compile/run it here but at the moment I just upgraded and have not yet installed much software. (I'm kind of busy these days.) Never used glut before either. I'll watch this thread for a bit in case you want me to try something further.
  12. Log File: Entered main Initialising Shaders Loading Textures Building Torus Building Cube Entering Main Loop Clearing Buffers Rendering Light Rendering Unlit Background Rendering Torus Torus Rendered Rendering Cube Cube Rendered Rendering Shadow Volumes Rendering Torus Shadow Torus Shadow Rendered Rendering Lit Objects Rendering Torus Torus Rendered Rendering Cube Cube Rendered Rendering Complete Clearing Buffers Rendering Light Rendering Unlit Background Rendering Torus Torus Rendered Rendering Cube Cube Rendered Rendering Shadow Volumes Rendering Torus Shadow Torus Shadow Rendered Rendering Lit Objects Rendering Torus Torus Rendered Rendering Cube Cube Rendered Rendering Complete
  13. After grabbing a copy of glut32.dll (ver 3.7.6) I ran your GlSlang.exe but the program crashed. The rendering window came up, was black, and it crashed in nvoglnt.dll Windows XP Pro Official Nvidia 66.93 Drivers 6800GT
  14. JotDot

    Please test my first shader test app!

    fps varies from 341 to 512 with effect off A solid 146 with it on 3Ghz P4, 256 Meg 6800GT
  15. JotDot

    alternative hd color spaces

    I too am not the best person to answer this but I do believe you should take a look at this: clicky
  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!