Litheon

Members
  • Content count

    104
  • Joined

  • Last visited

Community Reputation

288 Neutral

About Litheon

  • Rank
    Member
  1. Asset Importer Library 3.1.1. is out

    Cool!! I'm a happy user of assimp for many years now! Nice to see an update! Thank you very much!!
  2. Microsoft Illumiroom

    It surfaced again this week because of CHI2013 conference  (conference on computer human interaction) http://chischedule.org/2013/     And the paper: http://research.microsoft.com/en-us/projects/illumiroom/IllumiRoom_CHI2013_BJones.pdf
  3. "Macs are better for artists"

    It seems like I am the only person that is having huge problems with Xcode. It constantly crashes :s It is constantly indexing, which uses a lot of cpu When you compile it is using a massively amount of system memory, which makes my laptop run very very slow Intellisense in C++ is crap if you compare it with visual studio It takes a few seconds when you right click on a file #include <blabla.h> , but i think that is fixed now When you have a lot of code that is commented but is at the start of the line "<tab>// " then the uncomment function does not work (you need to left intent it first) A shortcut isnt a shortcut when you have to press 4 buttons at the same time. But that is maybe of my azerty keyboard. And I can continue.... Has xcode support for extensions? I haven't found it Intellisense does not work on std::vector std::map (so all stl libraries) I think you can finally read wchar_t strings In Visual Studio you can read out QStrings with intellisense without any problems, off course not in Xcode etc. But if you do a twitter search on "Xcode" it seems I am not the only one ... [url="http://twitter.com/#!/search/xcode"]http://twitter.com/#!/search/xcode[/url] So I don't really get all the positive things about it, so for me programming on OS X is pure hell
  4. Would be cool though, a DirectX/OpenGL documentary!
  5. --Game Hooking revisited--

    I think everybody is confused of what you exactly want to accomplish. Or on which game? For example, to get keypresses, if the game uses DirectInput you can hook directinput else you need to do it with SetWindowHookEx etc. To hook directx there is a topic + example here : [url="http://www.gamedev.net/topic/359794-c-direct3d-hooking-sample/page__hl__hooking"]http://www.gamedev.n...ge__hl__hooking[/url] Also on [url="http://www.codeproject.com"]http://www.codeproject.com[/url] there are several hooking examples. There is also the API of Microsoft [url="http://research.microsoft.com/en-us/projects/detours/"]http://research.micr...ojects/detours/[/url] that can be very helpful. First I would try to hook dx or opengl or win32 functions and then maybe see if you can hook functions in an .exe.
  6. [quote name='Adam_42' timestamp='1332518235' post='4924670'] Going by the description, the issue was that there's two copies of observable.h in different folders. Let's say they looked like this: [CODE] #ifndef OBSERVABLE_H #define OBSERVABLE_H class Observable { public: int x, y; }; #endif [/CODE] [CODE] #ifndef OBSERVABLE_H #define OBSERVABLE_H class Observable { private: int z; public: int x, y; }; #endif [/CODE] If you end up including different versions in different places (thanks to different include paths passed to the compiler) then they won't agree about the offsets of the x and y variables (and will almost certainly mess up the offsets of variables in derived classes too). This will cause all sorts of weird problems at runtime, but nothing will fail to compile because the public interfaces are identical. [/quote] Exactly!
  7. Yes Yes, I've found it! One BAZILLION reputation points for Adam_42!!!! It was the one definition rule! The class was derived from the class Observable. But I've discovered, because somebody did an "additional include directories" in the project properties, that this class existed on 2 places!!! Thus there were 2 function definitions for each function declaration! I've discovered it by changing the header guards (which used the same define) to "pragma once" and then the compiler complained about having multiple declarations!
  8. ahah, now it moved to the constructor! The constructor cant create a valid class [url="http://imageshack.us/photo/my-images/19/rrrpa.png/"][img]http://img19.imageshack.us/img19/2131/rrrpa.png[/img][/url] And the T_CallbackObserver is a template class.
  9. Rebuilding is the first thing I've tried, and I've got it on multiple machines. I will try valgrins next week (will take ages to run i think on such a big project ), currently I'm trying it with http://www.softwareverify.com/cpp-memory.php on windows. We will see, but I see those things as a last hope ... Mmmm, but the most "one definition rules" are detected by the compiler no? Once I could solve the problem by removing a forward declaration (the header file of the class was included + a forward declaration of the class). (Maybe the corruption just moved to somewhere else) Can forward declaration screw things over?
  10. Hey everyone, This is a little bit cry for help, like how the hell do I find this problem. Maybe anyone has some tips. I'm working in a big project (cross-platform Windows/MacOSX) and I'm having the problem on both operating systems. I've got a class and it does weird things. - Sometimes the class contains correct pointers, but when I try to access those pointers from outside they return invalid values (GetCurrentRenderLayerList() is a dead normal accessor (return currentRenderLayerList_), but it returns 0xcdcdcdcd instead of 0x07c28418 or returns sometimes 0x00000320 and other weird values). [url="http://imageshack.us/photo/my-images/42/screenshotproblem.png/"][img]http://img42.imageshack.us/img42/6904/screenshotproblem.png[/img][/url] The value in the green circle should be 0, but also got suddenly an invalid value. - Also sometimes I have the feeling that the memory is shifted by 4 bytes The "videoMappingResolution_" should have been 800 x 600, but in this case it is shifted, so it is 600 x "invalid value" and the pointer before it got the 800 (0x0000320) value. [url="http://imageshack.us/photo/my-images/688/screenshotproblem2.png/"][img]http://img688.imageshack.us/img688/8223/screenshotproblem2.png[/img][/url] - I also have the feeling it sometimes already goes wrong in the constructor or just after. So you create the class and some variables are already badly initialized (in the constructor I try to set all values to NULL and then I see that those values are like 0xcdcdcd or have another value). The only thing I can think about now is maybe a vtable corruption? How can this be caused? I've checked that I don't call the constructor twice , but I can't find where I'm doing that or so, I don't do anything special in that class. And for arrays I only use std::vector and std::map etc. So I don't think I overwrite some data with an array.