Jump to content
  • Advertisement

copacabana

Member
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

122 Neutral

About copacabana

  • Rank
    Member
  1. copacabana

    Browse button in MFC problem

    I do not have anything like "Microsoft Common Dialog Control". Besides I've been unaccurate. The problem is not with getting path to the file... it works but with the displaying accuired information in the edit box that part doesn't work.
  2. Hi! I wanted to create browse button on my dialog that opens a file open window and after choosing file it places path to the file in the edit box. Variable that I use to keep file name is named file_name :) It doesn't work. Any ideas why?? What should I change/add?? My code to handle button click event: void MyDialog::OnBnClickedBrowse() { // TODO: Add your control notification handler code here CFileDialog m_ldFile(TRUE); // Show the File open dialog and capture the result if (m_ldFile.DoModal() == IDOK) { // Get the filename selected file_name = m_ldFile.GetFileName(); UpdateData(TRUE); } }
  3. copacabana

    Problem with isExtensionSupported

    This is the code of function that is causing trouble: bool CMapReaderDoc::IsExtensionSupported(const char *szTargetExtension) { const unsigned char *pszExtensions; const unsigned char *pszStart; unsigned char *pszWhere=NULL, *pszTerminator; pszWhere = (unsigned char *)strchr(szTargetExtension,' '); if(pszWhere || *szTargetExtension == '\0') return false; pszExtensions = glGetString(GL_EXTENSIONS); pszStart = pszExtensions; for(;;) { pszWhere = (unsigned char *)strstr((const char *)pszStart, szTargetExtension); if(!pszWhere) break; pszTerminator = pszWhere + strlen(szTargetExtension); if(pszWhere == pszStart || *(pszWhere-1)==' ') if(*pszTerminator == ' ' || pszTerminator == '\0') return true; pszStart = pszTerminator; } return false; }
  4. copacabana

    VBOs and triangle strips

    Thanks a lot!
  5. copacabana

    Problem with isExtensionSupported

    Sorry for so few details. It's an mfc single document application that uses opengl. I'm trying to run isExtensionSupported to initialize my variable in class Doc in constructor for Doc class. I get something like this: Unhandled exception at 0x10215c4e (msvcr71d.dll) in MyAppMR.exe: 0xC0000005: Access violation reading location 0x00000000. and it directs me to strstr.asm to line: mov al,[edi] ; al is next char from str1 Anybody knows what it means?? Maybe the elves do?? :)
  6. I got this procedure in my program it compiles but when it runs an error occures. Visual Studio.Net shows me some strstr.asm assembler file and points to some instruction. I haven't changed anything there so I believe it should work properly :P Why doesn't it?? I have copied whole procedure so an error has to have something to do with strstr but why?? Should I write my own strstr function? Maybe I'm doing something wrong ? Any ideas??
  7. copacabana

    VBOs and triangle strips

    I don't know if i'm writing in the right place but since I'm a begginer to VBOs I believe it's appropriate :) So the point is that in NeHe tutorial about VBOs GL_TRIANGLES are used and I would like to use TRIANGLE_STRIPS. What do you think the format I keep my terrain data should be? What should I put in the buffer. How to draw these strips or can I do it as one strip?! I'm all new to these extension things and I found myself here because I just wrote my first application that has low fps :D Please help! Maybe you know some pages or articles about VBOs so I could learn more.
  8. copacabana

    MFC & OpenGl

    Thank you all you were very helpful. I have a lot to learn yet :)
  9. copacabana

    MFC & OpenGl

    I'm not really sure what am I doing but correct me if I'm wrong. Should I put the initialization lines like window styles, hbrBackground and so on (these from NeHe's createGLwindow function) into the CMyView::PreCreateWindow(CREATESTRUCT& cs) function in MFC?? Please help?! What now? Is this a good place to attach all those contexts? And where should I put globals?!
  10. copacabana

    MFC & OpenGl

    I have a problem. I have to put gl inside an SDI application on MFC. But of course I do not have bloody idea how to do this. If someone could help me with the correct code or some hints for example where to put functions from NeHe's tutorials. I'd be grateful for details.
  11. copacabana

    CsGL without settings

    I belive this project was abandonned, although it works. But it's not the point I'd like to ask. Does someone know how to use this CsGL without the window that appears at the very beginning, just to set the paremeters in the code and go stright into the application?? Thank you whoever will help me :D... or not
  12. copacabana

    SDL_image installation

    I know this may sound stupid and obvious to most of you but how do I install this SDL_image library and configure it to run with .NET? I've downloaded the win32 binary and have got 4 files .dll where should I put them or what option should I set in .NET for this library to work? Just setting library directories in options does not work. When I compile I get unresolved external symbol error.. Please help!
  13. Hello! I'm using Visual Studio.Net Visual C++ and Windows XP SP2. I've first rewritten, next copied and finally downloaded the code given in the NeHe tutorial lesson 3 and in window mode everything is as it supposed to be, however in fullscreen mode colors "gone mad"! To be precise red color is gone and the whole scene looks darker. I do not know if there is a problem with drivers of video card ATI Radeon 8500 or is there some other reason. Has anyone encountered this or similar problem?? If so do you know any explanation why this is happening?? Thank you in advance for help.. Screenshots how it changes: rwrzesniewski.strony.wi.ps.pl/full.jpg rwrzesniewski.strony.wi.ps.pl/wind.jpg
  14. Hello! I'm using Visual Studio.Net Visual C++. I've first rewritten, next copied the code given in the tutorial lesson 3 and in window mode everything is as it supposed to be, however in fullscreen mode colors "gone mad"! To be precise red color is gone and the whole scene looks darker. I do not know if there is a problem with drivers of video card ATI Radeon 8500 or is there some other reason. Has anyone encountered this or similar problem?? If so do you know any explanation why this is happening?? Thank you in advance for help..
  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!