CornyKorn21

Members
  • Content count

    95
  • Joined

  • Last visited

Community Reputation

624 Good

About CornyKorn21

  • Rank
    Member
  1. Multiple definition error

    Your definition of Object::ObjectID should be within a source file. Currently if you include your header file in multiple .cpp files the compiler will generate multiple instances of the ObjectID as you have it currently defined "int Object::ObjectID = 0" On a side note I'm not entirely certain how the compiler handles two declarations of a static with the same name in a base class and the derived class as well.
  2. It's part of my job to investigate.   Didn't keep a log of everything I changed but the debug context is now creating properly in my Win32 example. Haven't been able to remove the auxiliary buffers but at least on the Win32 example I was able to eliminate the depth/stencil so I have the option to manually create it later for use in an FBO. Not sure what I have set up wrong with GLFW that it still creates the depth/stencil.
  3. I guess my next question would be is what is the purpose of the auxiliary buffers?   For example if I were to set up a GBuffer for a deferred pipeline should I take advantage of the fact the auxiliary buffers exist and use those as my GBuffer surfaces instead of manually creating my own?   My guess is that I'm not guaranteed that they are going to exist. So I would want to allocate my own framebuffer/texture sets anyway. But then at that point it seems like I'm just throwing away usable GPU memory.
  4. Hi, I was wondering if anyone could answer a few questions I have about properly setting up an OpenGL 4.1 context on Windows. I scrapped together two quick code samples on my computer one using GLFW/GLEW and another creating my own window and using GLEW. I ran both code samples through gDEBugger and I'm a little confused by the results. Based on the way I set up my window in both of the samples below I expected to only see a "Front Buffer" and "Back Buffer" when I viewed the context in gDEBugger. Instead I am seeing a depth, back, front, and four auxiliary buffers. Do I have any control over the creation of those buffers? The other question I have is if I'm properly setting up my OpenGL context for Windows. The one issue I seem to be having is that if I specify WGL_CONTEXT_DEBUG_BIT_ARB in the sample where I create my own window it doesn't properly create a context.   Posted this over at the OpenGL forums as well. Thanks for any help.   GLFW/GLEW: #define GLEW_STATIC #define WIN32_LEAN_AND_MEAN #include <Windows.h> #include <GL/glew.h> #include <GLFW/glfw3.h> #include <GLM/glm.hpp> #include "Debugging/glDebugging.h" int main( int argc, char* argv[] ) { if( !glfwInit() ) return EXIT_FAILURE; // define glfw window hints #if defined( _DEBUG ) glfwWindowHint( GLFW_OPENGL_DEBUG_CONTEXT, GL_TRUE ); #endif glfwWindowHint( GLFW_OPENGL_PROFILE, GLFW_OPENGL_CORE_PROFILE ); glfwWindowHint( GLFW_OPENGL_FORWARD_COMPAT, GL_TRUE ); glfwWindowHint( GLFW_CONTEXT_VERSION_MAJOR, 4 ); glfwWindowHint( GLFW_CONTEXT_VERSION_MINOR, 1 ); glfwWindowHint( GLFW_OPENGL_DEBUG_CONTEXT, 1 ); glfwWindowHint( GLFW_DEPTH_BITS, 0 ); glfwWindowHint( GLFW_STENCIL_BITS, 0 ); glfwWindowHint( GLFW_ACCUM_RED_BITS, 0 ); glfwWindowHint( GLFW_ACCUM_GREEN_BITS, 0 ); glfwWindowHint( GLFW_ACCUM_BLUE_BITS, 0 ); glfwWindowHint( GLFW_ACCUM_ALPHA_BITS, 0 ); glfwWindowHint( GLFW_AUX_BUFFERS, 0 ); // open a window with GLFW GLFWwindow* pWindow = glfwCreateWindow( 640, 360, "LearnGL", nullptr, nullptr ); if( pWindow == nullptr ) { glfwTerminate(); return EXIT_FAILURE; } glfwMakeContextCurrent( pWindow ); // initialize GLEW glewExperimental = GL_TRUE; if( glewInit() != GLEW_OK ) { glfwTerminate(); return EXIT_FAILURE; } if( !GLEW_VERSION_4_1 ) { glfwTerminate(); return EXIT_FAILURE; } #if defined( _DEBUG ) GL::InitializeDebugging(); #endif GLuint frameBuffer; GLuint colorBufferTexture; glGenTextures( 1, &colorBufferTexture ); // Set up texture glActiveTexture( GL_TEXTURE0 ); glBindTexture( GL_TEXTURE_2D, colorBufferTexture ); glTexParameteri( GL_TEXTURE_2D, GL_TEXTURE_BASE_LEVEL, 0 ); glTexParameteri( GL_TEXTURE_2D, GL_TEXTURE_MAX_LEVEL, 0 ); glTexImage2D( GL_TEXTURE_2D, GLint( 0 ), GL_RGBA8, GLsizei( 640 ), GLsizei( 360 ), 0, GL_RGBA, GL_UNSIGNED_BYTE, nullptr ); glBindTexture( GL_TEXTURE_2D, 0 ); glPixelStorei( GL_UNPACK_ALIGNMENT, 4 ); // Set up frame buffer glGenFramebuffers( 1, &frameBuffer ); glBindFramebuffer( GL_FRAMEBUFFER, frameBuffer ); glFramebufferTexture( GL_FRAMEBUFFER, GL_COLOR_ATTACHMENT0, colorBufferTexture, 0 ); glBindFramebuffer( GL_FRAMEBUFFER, 0 ); while( !glfwWindowShouldClose( pWindow ) ) { // Viewport setup int width = 0; int height = 0; glfwGetWindowSize( pWindow, &width, &height ); glViewport( 0, 0, width, height ); // Clear render targets glBindFramebuffer( GL_FRAMEBUFFER, frameBuffer ); glClearBufferfv( GL_COLOR, 0, &glm::vec4( 1.0f, 0.0f, 5.0f, 1.0f )[0] ); glBindFramebuffer( GL_FRAMEBUFFER, 0 ); glClearBufferfv( GL_COLOR, 0, &glm::vec4( 0.1f, 0.1f, 0.1f, 1.0f )[0] ); glClearBufferfi( GL_DEPTH_STENCIL, 0, 1.0f, 0 ); glfwSwapBuffers( pWindow ); glfwPollEvents(); } return EXIT_SUCCESS; } Win32/GLEW [font='Helvetica Neue', Arial, Verdana, sans-serif]#define GLEW_STATIC[/font] #define WIN32_LEAN_AND_MEAN #include <Windows.h> #include <GL/glew.h> #include <GL/wglew.h> #include <GLM/glm.hpp> #include "Debugging/glDebugging.h" LRESULT CALLBACK WndProc( HWND, UINT, WPARAM, LPARAM ); struct RunInfo { bool bRunning; }; int main( int argc, char* argv[] ) { STARTUPINFO startInfo; HINSTANCE hInstance = ( HINSTANCE )GetModuleHandle( NULL ); GetStartupInfo( &startInfo ); WNDCLASSEX wcex; wcex.cbSize = sizeof( WNDCLASSEX ); wcex.style = CS_HREDRAW | CS_VREDRAW | CS_OWNDC; wcex.lpfnWndProc = WndProc; wcex.cbClsExtra = 0; wcex.cbWndExtra = 0; wcex.hInstance = hInstance; wcex.hIcon = LoadIcon( hInstance, MAKEINTRESOURCE( IDI_APPLICATION ) ); wcex.hCursor = LoadCursor(NULL, IDC_ARROW); wcex.hbrBackground = ( HBRUSH )( COLOR_WINDOW + 1 ); wcex.lpszMenuName = NULL; wcex.lpszClassName = L"NoGLFW"; wcex.hIconSm = LoadIcon( hInstance, MAKEINTRESOURCE( IDI_APPLICATION ) ); if( !RegisterClassEx( &wcex ) ) return -1; RECT rc = { 0, 0, 640, 360 }; AdjustWindowRectEx( &rc, WS_OVERLAPPEDWINDOW, FALSE, WS_EX_APPWINDOW | WS_EX_WINDOWEDGE ); HWND hWnd = CreateWindowEx( WS_EX_APPWINDOW | WS_EX_WINDOWEDGE, L"NoGLFW", L"NoGLFW", WS_OVERLAPPEDWINDOW, 0, 0, rc.right - rc.left, rc.bottom - rc.top, NULL, NULL, hInstance, NULL ); if( !hWnd ) return -1; PIXELFORMATDESCRIPTOR pfd = { sizeof( PIXELFORMATDESCRIPTOR ), // Struct size 1, // Version PFD_DRAW_TO_WINDOW | PFD_SUPPORT_OPENGL | PFD_DOUBLEBUFFER, // Support OpenGL/Double Buffering PFD_TYPE_RGBA, // Request RGBA format 32, // Output color depth 0, 0, 0, 0, 0, 0, // Color bits, ignored 0, // No alpha buffer 0, // Shift bit, ignored 0, // No accumulation buffer 0, 0, 0, 0, // Accumulation bits, ignored 0, // No z-buffer 0, // No stencil buffer 0, // No auxillary buffer PFD_MAIN_PLANE, // Main drawing layer 0, // Reserved 0, 0, 0 // Layer masks, ignored }; HDC hDc = GetDC( hWnd ); if( !hDc ) return -1; unsigned int pixelFormat = ChoosePixelFormat( hDc, &pfd ); if( !pixelFormat ) return -1; if( !SetPixelFormat( hDc, pixelFormat, &pfd ) ) return -1; HGLRC tempContext = wglCreateContext( hDc ); wglMakeCurrent( hDc, tempContext ); glewExperimental = GL_TRUE; GLenum err = glewInit(); int attribs[] = { WGL_CONTEXT_MAJOR_VERSION_ARB, 4, WGL_CONTEXT_MINOR_VERSION_ARB, 1, WGL_CONTEXT_FLAGS_ARB, WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB, WGL_CONTEXT_PROFILE_MASK_ARB, WGL_CONTEXT_CORE_PROFILE_BIT_ARB, WGL_CONTEXT_FLAGS_ARB, 0, 0 }; HGLRC hRc = tempContext; if( wglewIsSupported( "WGL_ARB_create_context" ) == 1 ) { hRc = wglCreateContextAttribsARB( hDc, 0, attribs ); wglMakeCurrent( NULL, NULL ); wglDeleteContext( tempContext ); wglMakeCurrent( hDc, hRc ); } //Checking GL version const GLubyte* GLVersionString = glGetString( GL_VERSION ); //Or better yet, use the GL3 way to get the version number int OpenGLVersion[2]; glGetIntegerv( GL_MAJOR_VERSION, &OpenGLVersion[0] ); glGetIntegerv( GL_MINOR_VERSION, &OpenGLVersion[1] ); RunInfo runInfo; runInfo.bRunning = true; SetWindowLongPtr( hWnd, GWLP_USERDATA, ( LONG_PTR )&runInfo ); ShowWindow( hWnd, SW_SHOWDEFAULT ); UpdateWindow( hWnd ); MSG msg = { 0 }; while( runInfo.bRunning ) { if( PeekMessage( &msg, hWnd, 0, 0, PM_REMOVE ) ) { TranslateMessage( &msg ); DispatchMessage( &msg ); } glViewport( 0, 0, 640, 360 ); glClearBufferfv( GL_COLOR, 0, &glm::vec4( 0.1f, 0.1f, 0.1f, 1.0f )[0] ); SwapBuffers( hDc ); } return 0; } LRESULT CALLBACK WndProc( HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam ) { RunInfo* pRunInfo = ( RunInfo* )GetWindowLongPtr( hWnd, GWLP_USERDATA ); switch( message ) { case WM_DESTROY: { pRunInfo->bRunning = false; PostQuitMessage( 0 ); } break; } return DefWindowProc( hWnd, message, wParam, lParam ); }
  5. Have Solution/Project for both VS2010/2012

    If you require people to use different toolsets for working on your code base I would suggest using a utility like CMAKE or Premake to generate the solution/projects. This way you distribute the CMAKE or Premake files and people can have those build the VS/make/XCode projects that are required for what you are working on.   I modified the premake source a little while back in order to make it work with VS2012. I can probably post it online later today if you consider that as an option.
  6. I have posted this on the Autodesk forums and Google group. Although there is zero activity, so not quite sure where else to go except here. I'm attempting to write a scene exporter using the 3DS Max .NET SDK. I currently have what I thought was the bare minimum setup in order to create an exporter. After building the DLL I copy it into the bin/assemblies directory and launch MAX 2013 and attempt an export. I receive the message "An error has occurred and the application will now close. No scene changes have occurred since your last save." I copy and pasted the Descriptor and Loader from the example in [url="http://area.autodesk.com/blogs/chris/3ds-max-2013-net-sdk-and-the-maxsharp-source-code."]http://area.autodesk...rp-source-code.[/url] Do I have something set up wrong in my code that could cause this issue? My project references Autodesk.Max and the "Copy Local" is set to false. [code] using System; using System.Collections.Generic; using System.Linq; using System.Text; using Autodesk.Max; namespace TestExporter { public class TestExporter : Autodesk.Max.Plugins.SceneExport { public override string AuthorName { get { return "Test"; } } public override string CopyrightMessage { get { return "Test"; } } public override int DoExport(string name, Autodesk.Max.IExpInterface ei, Autodesk.Max.IInterface i, bool suppressPrompts, uint options) { return 1; } public override string Ext(int n) { return "mesh"; } public override int ExtCount { get { return 1; } } public override string LongDesc { get { return "Test Export Utility"; } } public override string OtherMessage1() { return ""; } public override string OtherMessage2() { return ""; } public override string ShortDesc { get { return "Test"; } } public override void ShowAbout(IntPtr hWnd) { return; } public override uint Version { get { return 1; } } } public class Descriptor : Autodesk.Max.Plugins.ClassDesc2 { public override string Category { get { return "Test"; } } public override IClass_ID ClassID { get { return Loader.Global.Class_ID.Create(0x3990388b, 0x696868d0); } } public override string ClassName { get { return "Test Export Utility"; } } public override object Create(bool loading) { return new TestExporter(); } public override bool IsPublic { get { return true; } } public override SClass_ID SuperClassID { get { return SClass_ID.SceneExport; } } } public static class Loader { public static IGlobal Global; public static IInterface13 Core; public static void AssemblyMain() { Global = Autodesk.Max.GlobalInterface.Instance; Core = Global.COREInterface13; Core.AddClass(new Descriptor()); } } } [/code]
  7. [quote name='Rexxaw(Forgrim's mate)' timestamp='1334862730' post='4932907'] I know nothing of threading. If i were to use this method, would it be safe? Or does it require careful design and coding to ensure that the app remains single -threaded? Thanks. [/quote] Short answer is that a basic application is single threaded, so yes it will be safe. You don't get into threading unless you create additional threads. Something like this hello world is considered single threaded. [code] int main( int argc, char* argv[] ) { printf("Hello, world!\n"); return 0; } [/code]
  8. Dumbest coding mistakes ever

    [code] while( someCondition ); { } [/code]
  9. [quote name='Washu' timestamp='1328267044' post='4909095'] [CODE] // insert code here int main(int argc, char* argv) { //TODO //Initialize Systems //Load data //Update world //Render return 0; } [/CODE] [/quote] I'll start :-P
  10. Have you considered using something like Unity, UDK or another engine? There are many freely available options to do what you are requesting.
  11. WPF & DirectX 11 via D3DImage

    Great! Sorry I wasn't much help.
  12. WPF & DirectX 11 via D3DImage

    Shoot, sorry, I completely misread your original post. I did mine using SlimDX. I'll grab the code you're working with and give it a shot tonight if I can remember.
  13. WPF & DirectX 11 via D3DImage

    Can you post some of your code? I don't really have any solutions to your problem. I was able to take the sample code and mostly just change "DirectX10" to "DirectX11" and using the device context. If no one gives you a solution by the time I get home from work tonight I'll post what I have.
  14. SDL_Surface in a struct

    [quote name='chosenkill6' timestamp='1317079975' post='4866264'] Lol, need some more help Here is the program that i made just to test the struct in and as soon as it runs, it stops responding. Some help please [code] #include <SDL.h> #include <SDL_image.h> #include <string> SDL_Surface *screen = NULL; SDL_Surface *load_image(std::string filename) { SDL_Surface *loaded_image = NULL; SDL_Surface *optimized_image = NULL; loaded_image = IMG_Load(filename.c_str()); optimized_image = SDL_DisplayFormatAlpha(loaded_image); SDL_FreeSurface(loaded_image); return optimized_image; } struct object { float x_coordinate, y_coordinate; float x_speed, y_speed; SDL_Surface *image; }; int main(int argc, char *args[]) { SDL_Init(SDL_INIT_EVERYTHING); screen = SDL_SetVideoMode(800,600,32,SDL_SWSURFACE); SDL_WM_SetCaption("Pong", NULL); object left_paddle, right_paddle, ball; ball.image = load_image("ball.png"); left_paddle.image = load_image("left_paddle.png"); right_paddle.image = load_image("right_paddle.png"); SDL_BlitSurface(left_paddle.image, NULL, screen, NULL); SDL_Flip(screen); SDL_Delay(5000); SDL_Quit(); return 0; } [/code] [/quote] Need a little more information. What do you mean it stops responding? Do you know where it stops responding if it actualy does? From what I can see it looks like it is set to render the left paddle on screen for approximately 5 seconds and then quit.
  15. SDL_Surface in a struct

    [quote name='chosenkill6' timestamp='1317079440' post='4866262'] [quote name='CornyKorn21' timestamp='1317079185' post='4866259'] [quote name='chosenkill6' timestamp='1317079048' post='4866258'] I am trying to put an SDL_Surface into a struct but i keep getting error saying it forbids initialization of member "variable name", plus many more errors... How would i go about doing this. Does it have something to do with the fact that an SDL_Surface is a struct? I am lost, some help would be greatly appreciated. here is the struct i am trying to make: [code]struct object { float x_coordinate, y_coordinate; float x_speed, y_speed; SDL_Surface *image = NULL; };[/code] [/quote] [code]struct object { float x_coordinate, y_coordinate; float x_speed, y_speed; SDL_Surface *image; };[/code] You can't set *image to NULL like that. Should solve your issue, I believe. [/quote] Yeah, that worked like a charm.Thanks Just wondering, why is that so? Whenever i declare a surface in any function i set it to NULL, why is that not possible here? [/quote] Someone else may need to chip in here, I'm not sure of the exact reasoning behind not allowing default values in stuct/class definitions. Default values should be set through a constructor. I think the only exception for that are const members.