Jump to content

View more

Image of the Day

Inventory ! Va falloir trouver une autre couleur pour le cadre D: #AzTroScreenshot #screenshotsaturday https://t.co/PvxhGL7cOH
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Allegro and MIDIs

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
1 reply to this topic

#1 rgillen   Members   

122
Like
Likes
Like

Posted 26 June 2000 - 03:44 AM

Hello, I have been experimenting with the Allegro game development package and I had a question about playing MIDI files. When I listen to them in Windows they sound great, but when they play in my Allegro-made game, they sound terrible. Are Windows and my game using different MIDI players? If so, how can I get my game to use the better one? And most importantly, how can I ensure that my game will use my users'' best player. Thanks, Rob

#2 Julio   Members   

116
Like
Likes
Like

Posted 26 June 2000 - 04:05 AM

With Allegro when you call:
install_sound(...)
if you are calling DIGI_AUTODETECT,MIDI_AUTODETECT); try using different sound devices. If you are using the different sound devices the try calling the above.

JoeMont001@aol.com




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.