Jump to content

View more

Image of the Day

Working on an auto spawn system. #gamedev #indiedev #screenshotsaturday https://t.co/Mm2kfekz7b
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

gluPerspective (undefined reference???)

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
3 replies to this topic

#1 sab3156   Members   

109
Like
0Likes
Like

Posted 17 May 2005 - 04:08 PM

I am running opengl through Dev-C++. here is my linker output: ___________________ c:\programming\game\_main.o(.text+0x84):_main.cpp: undefined reference to `gluPerspective@32' ___________________ what is this about?? how can i fix this problem?

#2 extralongpants   GDNet+   

704
Like
0Likes
Like

Posted 17 May 2005 - 04:21 PM

I'm not totally familiar with dev-c++ compiler messages, but I'm pretty sure it just means you aren't linking your project to glu32.lib



#3 Drew_Benton   Members   

1848
Like
0Likes
Like

Posted 17 May 2005 - 04:35 PM

Quote:
Original post by odiousangel
I'm not totally familiar with dev-c++ compiler messages, but I'm pretty sure it just means you aren't linking your project to glu32.lib


Correct, to link in that .lib file to Dev-CPP you need to add in -lglu32 to the Linker Box in Project->Project Options->Parameters.

#4 kburkhart84   Members   

3094
Like
0Likes
Like

Posted 17 May 2005 - 04:57 PM

With visual c++, when you link something using the project options, it links it only for the application from within the IDE. To make it link the libs to the actual .exe, you need to put a precompiler message in there. But I could be wrong, this is how I understood it. It may or may not apply to your compiler/IDE(Dev C++).




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.