Jump to content

View more

Image of the Day

Inventory ! Va falloir trouver une autre couleur pour le cadre D: #AzTroScreenshot #screenshotsaturday https://t.co/PvxhGL7cOH
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

glPolygonMode slows down[solved]

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • This topic is locked This topic is locked
23 replies to this topic

#21 gold   Members   

412
Like
0Likes
Like

Posted 02 September 2006 - 05:35 AM

Line thickness is not the issue, at least on NVIDIA hardware. I'll be happy to solve this mystery as soon as MARS_999 provides a reproducer. :)

#22 MARS_999   Members   

1620
Like
0Likes
Like

Posted 13 September 2006 - 09:14 AM

Solution has been found and reason why, thanks to Gold.

Reason is
It’s an interaction between user clip planes and polygon mode.


Solutions are

You have a few options to work around this.
1) Use a vertex program instead of fixed function. You’ll have to implement your own user clipping, as that is part of fixed function. We don’t fall back in this case.

2) Use lines instead of triangles in line mode

3) Disable user clipping in wireframe mode



#23 Neosettler   Members   

150
Like
0Likes
Like

Posted 15 March 2013 - 08:34 AM

Hello Mars, excuse me to bring this thread from the grave but I'm having a major performance drop while rendering in GL_Line mode. I try to find information on how to disable the user clipping and I couldn't find anything so far... so my question is, how do you disable the user clipping?



#24 swiftcoder   Senior Moderators   

18216
Like
0Likes
Like

Posted 15 March 2013 - 01:05 PM

@Neosettler: please create a new thread to address this question.


Tristam MacDonald - Software Engineer @ Amazon - [swiftcoding] [GitHub]





Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.