Jump to content

View more

Image of the Day

The night is still, but the invasion brings chaos. #screenshotsaturday #hanako #indiegame #gameart #ue4 #samurai https://t.co/cgILXuokoS
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

DevIL Library

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
3 replies to this topic

#1 shinydarkstone   Members   

100
Like
0Likes
Like

Posted 29 June 2009 - 02:54 AM

hi, im stuck at the lesson 6 with DevIL library, i linked the dll to my project but when i do the include
#include <IL\il.h>
it says that it cant find the library. i copied the dlls to my windows\system folder, but still no luck somebody know how to use DevIL in microsoft windows with VS2008? any help will be apreciated. TIA

#2 Kazade   Members   

1019
Like
0Likes
Like

Posted 29 June 2009 - 04:10 AM

I think you need to download the Windows SDK version from here: http://openil.sourceforge.net/download.php and link to the *.lib files.

I can't test atm coz I don't have access to Windows/VC++ :)

#3 Kwizatz   Members   

1380
Like
0Likes
Like

Posted 29 June 2009 - 05:19 AM

The SDK is just a zip containing the link time libraries and headers, you'd still have to add the proper paths to those in Visual Studio (Tools->Options->Projects And Solutions->VC++ Directories->Show Directories for: Include files / Library Files).

If you had already done that, then I would use


#include "IL/il.h"


instead of


#include <IL\il.h>


For two reasons, first the <> are used for system headers, which il.h is not and second, because \ is Windows specific and thus, not portable.


#4 shinydarkstone   Members   

100
Like
0Likes
Like

Posted 29 June 2009 - 02:59 PM

tnx both of you.
it worked!!!!
i didnt have the lib files, so i needed to download them
tnx Kazade for the link
also i didn have the paths configured
so i followed the Kwizatz instructions and worked;
again, tnx both




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.