Jump to content

View more

Image of the Day

The night is still, but the invasion brings chaos. #screenshotsaturday #hanako #indiegame #gameart #ue4 #samurai https://t.co/cgILXuokoS
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Intresting Problem...

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
4 replies to this topic

#1 Marvin   Members   

127
Like
Likes
Like

Posted 05 August 2001 - 05:46 AM

ok here it goes, i have an Orthographic layer in front of my 3d sceen. The problem is i want to rotate on object on the Z axis in the ortho layer. How can i do this? when i rotate the object just seems to get clipped. Thanks

#2 kren   Members   

122
Like
Likes
Like

Posted 05 August 2001 - 08:24 AM

well, you mustn''t rotate ''all at once''. not like this:

glRotate3f(180,0.0f,0.0f,1.0f);

what you have to do is set-up a variable and rotate by small steps:

GLfloat rot_angle=0.0;
glRotate3f(rot_angle,0.0f,0.0f,1.0f);
rot_angle+=0.1;

if i correctly understand your problem.

#3 Marvin   Members   

127
Like
Likes
Like

Posted 05 August 2001 - 08:50 AM

its fair to say you dont understand the problem :o/ ill post when i can think of a way anyoen can understand

#4 Nairb   Members   

757
Like
Likes
Like

Posted 05 August 2001 - 11:52 AM

Are you sure your z-near and z-far clipping planes are large enough to accomodate the entire image? If they''re too small ( like if you were to use Ortho2D ), then the entire image will get clipped.

--Nairb

#5 Marvin   Members   

127
Like
Likes
Like

Posted 05 August 2001 - 10:28 PM

when creating the ortho view i''ve tried setting the z axis range upto 16 to -16 still same effect :o/ tell me more




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.