Jump to content

View more

Image of the Day

WIP title screen for #DeathOfAPartisan #screenshotsaturday #gamedev https://t.co/qJNhfZCvd4
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.

Sign up now

Allegro Installation Issues

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 Jefficorn   Members   


Posted 16 December 2011 - 01:44 PM

First off, if this is the wrong forum, I apologize. This is my first time posting on this website.

Anyway, I spent a large portion of yesterday and all day today trying to install Allegro and the related programs to Code::Blocks and am starting to get frustrated (I have a lot of patience, but two days to install a program is a little much for me). What I aim to do in this thread is show you what I have done and where I have gotten to allow you to help me finish this out.

The main two tutorials on installation I have used are:
I have two C++ Compilers on my computer:
Visual C++ 2010

I generally use Code::Blocks; it is my main compiler.

First, I downloaded Allegro 5, then read the "read me".
It said I needed DirectX and another program.
That other program installed just fine.
After a 30 minute download, I had directX on my computer, so I tried to install it. Each installation attempt takes around 10 minutes, so making small changes and trying again took awhile, but here's what I did:
The first installation attempt gave me error S1023. It recommended I close all other programs and try again, so I did that.
I tried to install it again without programs, same error.
I realized Steam was still running in my processes so I tried again after closing Steam. Same error.
I restarted my computer and tried again. Same error.
I then consulted the internet about the error. It became apparent that I should get MinGW onto my computer, so that's what I did.
I then downloaded MinGW onto my computer and began using the tutorials above.
I edited the pathways, as suggested.
After a long search, I learned what the tutorials meant by "Get to C:\allegro." and "Change the directory" and other terms.
It all seemed to work, but a disagreement in a command they showed and my result has me worried. <-------- One thing I need help on. How do I fix this: http://screensnapr.com/v/1bV1zA.png
I then downloaded dx70 as recommended and extracted the files to MinGW.
I then downloaded allegro 4.2.2 since that was what the tutorial recommended and extracted it to MinGW.


The first website tells me to do this: http://screensnapr.com/v/XKGH4F.png
and the second website tells me to do this: http://screensnapr.com/v/Eyvi55.png

I have tried both and I get these errors: http://screensnapr.com/v/HobtHv.png

I'm really lost as to what to do next. I've spent an enormous amount of time looking at various tutorials, youtube vids, etc., but nothing has seemed to work. I have only another good hour or two left before I don't have any free time today, so it's looking like tomorrow will be day 3 of trying to get this installed. PLEASE HELP!

I'll post a few miscellaneous screenshots below to give you some idea of what's going on in my computer, maybe there's a mistake in one of them? I don't know.

Pathways: http://screensnapr.com/v/HobtHv.png
Contents of MinGW: http://screensnapr.com/v/KwmJfw.png
Contents of Allegro: http://screensnapr.com/v/qvcYxH.png

If it helps you to answer the question for me to show you any of the folders within those programs, or anything else that will help, please let me know.
Thanks in advance,


#2 Jefficorn   Members   


Posted 17 December 2011 - 12:19 PM

Today I try again.

Screenshot by screenshot what I do today to help any helpers:
1. http://screensnapr.com/v/0i2ecm.png --- downloaded "allegro-5.0.5-mingw-4.5.2"
2. http://screensnapr.com/v/frhak1.png --- extracted all folders to location c:\allegro

from there I followed the tutorial at: http://wiki.allegro.cc/index.php?title=Windows,_Visual_Studio_2010_and_Allegro_5 perfectly.

Then after following all steps, attempted to run it as suggested and got this error:
"1>c:\users\jacob\documents\visual studio 2010\projects\seeingifallegroworks\seeingifallegroworks\main.cpp(2): fatal error C1083: Cannot open include file: 'allegro5/allegro.h': No such file or directory"

I have now tried to install allegro onto multiple compilers, using multiple tutorials, with every single version of allegro available. I'm really lost, I don't know if I need to unistall other things to try again or what, but I now have multiple versions of mingw and allegro doing nothing on my computer, as well as whatever folders have been created from a dozen attempts to install directX. If anyone can help me with this, I'd appreciate it. It has been 3 days, and I'm getting kind of desperate...

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.