Jump to content

View more

Image of the Day

The night is still, but the invasion brings chaos. #screenshotsaturday #hanako #indiegame #gameart #ue4 #samurai https://t.co/cgILXuokoS
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Visual Studio "Generating Code" infinitely

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
3 replies to this topic

#1 osiris_dev   Members   

289
Like
1Likes
Like

Posted 27 June 2012 - 03:26 AM

There was a problem with linking code in release mode. To be more precise after compiling begins "Generating Code" but never ending. I made a couple of tests and found that the reason connect with "Maximaze Speed" flag in C++ Optimization.

I have other projects for VS2010 SP1 but they have not problems.

Any ideas?

#2 Misery   Members   

354
Like
0Likes
Like

Posted 27 June 2012 - 03:48 AM

Well, I have found a several bugs in VS2010 Ultimate as well. For example when there was access violation due to accessing reference that didn't exist in C++, debugger hangs. I think that using VS2008 or reporting bugs and waiting for patches is a solution really. Posted Image

#3 Cygon   Members   

1219
Like
0Likes
Like

Posted 27 June 2012 - 04:43 AM

I have compiled tons of libraries (including some big ones like Ogre 3D that took up gigabytes of disk space for temporary build files) but never encountered this.

If you have enabled LTCG (Whole Program Optimization), the compiler will not actually compile your sources, but write the preprocessing results into the .obj files. When the linker prints "Generating Code", it will combine all of the sources into one huge source file and compile that. I know that on a lower-end system I had to wait several minutes for this step to complete.
Professional C++ and .NET developer trying to break into indie game development.
Follow my progress: http://blog.nuclex-games.com/ or Twitter - Topics: Ogre3D, Blender, game architecture tips & code snippets.

#4 osiris_dev   Members   

289
Like
0Likes
Like

Posted 27 June 2012 - 08:56 AM

If you have enabled LTCG (Whole Program Optimization), the compiler will not actually compile your sources, but write the preprocessing results into the .obj files. When the linker prints "Generating Code", it will combine all of the sources into one huge source file and compile that. I know that on a lower-end system I had to wait several minutes for this step to complete.


Yes, I have enabled LTCG. Now I removed some codes and generating finished. Last time i waited 30 minutes but i don't saw result. This time it took 1 min. So, i don't know how I can boost generation time.




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.