Jump to content

View more

Image of the Day

#ld38 #screenshotsaturday Mimosa Fizz action gif #2 https://t.co/TUzdppvfUL
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.

Sign up now

default xna 4.0 gametime don´t works well for physics

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 EusKoder   Members   


Posted 07 September 2012 - 08:33 PM

I am developing a game using Visual Studio 2010 and XNA 4.0,
after advancing to some extent with the project (a platform based 2d platformer msdn starter kit) I got to test it on different computers with different hardware (CPU, graphics, etc.) and I found that the speed of movement object of the game is quite different, I implemented the PSK physics msdn that are based on time,

		/// <summary>
		/// Updates the player's velocity and position based on input, gravity, etc.
		/// </summary>
		public void ApplyPhysics(GameTime gameTime)
			float elapsed = (float)gameTime.ElapsedGameTime.TotalSeconds;
			Vector2 previousPosition = Position;
			// Base velocity is a combination of horizontal movement control and
			// acceleration downward due to gravity.
			velocity.X += movement * MoveAcceleration * elapsed;
			velocity.Y = MathHelper.Clamp(velocity.Y + GravityAcceleration * elapsed, -MaxFallSpeed, MaxFallSpeed);
			velocity.Y = DoJump(velocity.Y, gameTime);
			// Apply pseudo-drag horizontally.
			if (IsOnGround)
				velocity.X *= GroundDragFactor;
				velocity.X *= GroundDragFactor;
				//velocity.X *= AirDragFactor;
			// Prevent the player from running faster than his top speed.		  
			velocity.X = MathHelper.Clamp(velocity.X, -MaxMoveSpeed, MaxMoveSpeed);
			// Apply velocity.
			Position += velocity *elapsed;
			Position = new Vector2((float)Math.Round(Position.X), (float)Math.Round(Position.Y));
			// If the player is now colliding with the level, separate them.
			// If the collision stopped us from moving, reset the velocity to zero.
			if (Position.X == previousPosition.X)
				velocity.X = 0;
			if (Position.Y == previousPosition.Y)
				velocity.Y = 0;
				jumpTime = 0.0f;

tested eg with a PC (PC1) 2.13GHz Intel Core 2 6400 / ATI Radeon HD 4670
and another one: (pc2) 3.00GHz Intel Pentium D / Intel 82945G Express Chipset Family
by displacement difference (moving x axis at supossed (position = velocity * gametime.ElapsedGameTime.TotalSeconds) constant velocity, for example) is 3 seconds in a total of 20 (example: moving pc1 player sprite 6000 pixels in the x-axis at 20 seconds and pc 2 runs the same distance in 17 ).
Tested on a 3rd PC: i72700k / Gigabyte GTX 560 TI
the results are even worse, after some time after starting the game gets like 3 times slower and showing the number of pixels in each frame moved in a debug window in the game (counting updatespersecond with counter variable for updates cuantity and gametime for counting a second show 63fps), it appears as if the number is always constant ( refreshments lose the Update method?).
In this pc if I put the game in fullscreen during the course of the game, the effect of "go slow" is immediate and restore window mode sometimes yield returns to "normal" and sometimes not.
Eventually I began to try a new project to test whether the movement is constant in different pc loading only one sprite and its position value in screen printing.
Occur The same.
I even tried moving a constant amount of pixels explicitly (position + = 5) and different speeds in different pc quantities of pixels moved in x time.
I have the game loop as the default (fixedTimeStep = true ;).
I've also tried turning off and creating another timestep as discussed in different post (eg http://gafferongames...-your-timestep/
but i can´t achieve the desired result, move the same number of pixels in X seconds on different computers with windows.
All pc used for tests use windows 7 enterprise pc1 == x86 the others are x64.

The weirdest thing is that I find information about people describing the same problem and that I wear long nights of searches.

Thanks for your help.

Edited by EusKoder, 07 September 2012 - 05:00 PM.

#2 ShadowValence   Members   


Posted 07 September 2012 - 06:14 PM

Disregard this post - I just re-read and it says you've attempted to disable fixed time stepping. Did you look into the V-Synch as well?

IDK - but it sounds like you may have a problem with the fixed time stepping and/or synch refresh lock in the XNA platform. To maintain a constant draw rate of approximately 60fps, XNA will drop update calls. And perhaps (I'm grasping at straws here) the gameTime doesn't reflect that it's had 10 dropped update calls.

If no one else posts, try setting IsFixedTimeStep to false and GraphicsDeviceManager,SynchronizeWithVerticalRetrace to false as well. See if your results are any different. I suppose it's worth a shot...


Edited by ShadowValence, 07 September 2012 - 06:15 PM.

#3 EusKoder   Members   


Posted 17 September 2012 - 03:06 PM

Problem "solved" the pixel amount difference between computers is because i have a fixedtimestep disabled and one of the tested computers monitor refresh rate is 75hz
If the monitor run at 75hz, in xna with isfixedtimestep=false and vsync actived the game run update 75 times per second.
When the two and more tested pcs are configured at 60hz in all of them works well and at same movement velocity.

Edited by EusKoder, 17 September 2012 - 03:07 PM.

#4 Bacterius   Members   


Posted 17 September 2012 - 03:12 PM

Well that's not really a fix, is it? If a monitor is capable of refreshing 75 times a second it makes little sense to clamp it down to 60Hz because of technical difficulties - you want to take into account the frametime when doing your physics, this will give you more stable physics.

“If I understand the standard right it is legal and safe to do this but the resulting value could be anything.”

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.