Move moves; shouldn't this be Move moves for this ?
Ooops! I shouldn't post code that I wrote late at night.
I think it should actually be 34 (31 non-empty combinations for bringing figures out of the base plus 3 moves). But 35 wouldn't hurt anything.