Jump to content

View more

Image of the Day

Boxes as reward for our ranking mode. ヾ(☆▽☆)
#indiedev #gamedev #gameart #screenshotsaturday https://t.co/ALF1InmM7K
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Carve Library - Rendering in DirectX Problem

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
1 reply to this topic

#1 sara_DE   Members   

127
Like
0Likes
Like

Posted 26 September 2012 - 10:18 PM

Hi

I am using Carve library for my experiment project in DirectX, and the results are coming good, but when i am rendering into my DirectX code, the output mesh seems not looking good (the visual only), is it because of my lighting?, i am using directional light with phong shade (a simple light), when i export the output (.obj format), and opens it in 3D Studio Max, in there also it is looking not good, but with "Object Smooth Groups" Option Enabled in 3ds max Import Dialog, then it is rendered good. And in "Carve Viewer" also, the results looking good, what do i do?, is there a problem with my lighting?, or is there a option in carve library itself?, or any "Smoothing functions" are needed before rendering it? .

Any Suggestions?

Thanks.

I attached the pictures


Picture 1: Rendered in "3D Studio Max 7" with "Object Smooth Groups" Option Enabled in Import Dialog.
Picture 2: rendering in My DirectX Code

Attached Thumbnails

  • 2.jpg
  • 1.jpg

Edited by sara_DE, 26 September 2012 - 10:19 PM.


#2 Ripiz   Members   

538
Like
0Likes
Like

Posted 27 September 2012 - 03:19 AM

It seems normals are different in your DirectX application.
If there is such option, you need to change smoothing angle (or hard edge angle) when exporting.




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.