Jump to content

View more

Image of the Day

Boxes as reward for our ranking mode. ヾ(☆▽☆)
#indiedev #gamedev #gameart #screenshotsaturday https://t.co/ALF1InmM7K
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

How to create a 2.1 context on recent Nvidia hardware?

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
6 replies to this topic

#1 Neosettler   Members   

150
Like
0Likes
Like

Posted 30 November 2012 - 01:17 PM

Greetings everyone,

back in the not so distant past, I was able to create a 2.1 context on 4.x hardware. I'm using a GeForce 690 with the 306.97 driver. It seems like the driver select the highest available context depend on the video card capabilities event when asking for a 2.1 context.

I use SFMLto create the GLcontext and the head developer is saying that he cant do nothing about this automated feature.

I looked in the Nvidia control panel and there is nothing regard this issue, how is that possible?

#2 Brother Bob   Moderators   

10274
Like
1Likes
Like

Posted 30 November 2012 - 01:26 PM

There is no way to request a specific version before 3.0, but it doesn't matter anyway since nothing changes for new versions.

#3 Neosettler   Members   

150
Like
0Likes
Like

Posted 30 November 2012 - 01:29 PM

^^ Yikes, alright then, thank you for your input Brother!

#4 swiftcoder   Senior Moderators   

18213
Like
0Likes
Like

Posted 30 November 2012 - 01:58 PM

it doesn't matter anyway since nothing changes for new versions.

To clarify that a little, while newer versions of OpenGL add many features, they don't take any away (unless you specifically request a 'Core' profile, which will prevent the use of all deprecated functionality).

Tristam MacDonald - Software Engineer @ Amazon - [swiftcoding] [GitHub]


#5 Neosettler   Members   

150
Like
0Likes
Like

Posted 30 November 2012 - 02:07 PM

(unless you specifically request a 'Core' profile, which will prevent the use of all deprecated functionality).


Thank you for your clarification swiftcoder and how do you specify this exactly?

#6 swiftcoder   Senior Moderators   

18213
Like
0Likes
Like

Posted 30 November 2012 - 02:40 PM

Thank you for your clarification swiftcoder and how do you specify this exactly?

As far as I am aware, SFML doesn't support requesting a core profile.

See https://github.com/L...SFML/issues/176

Tristam MacDonald - Software Engineer @ Amazon - [swiftcoding] [GitHub]


#7 Aks9   Members   

1486
Like
0Likes
Like

Posted 30 November 2012 - 06:33 PM

It seems like the driver select the highest available context depend on the video card capabilities event when asking for a 2.1 context. I use SFMLto create the GLcontext and the head developer is saying that he cant do nothing about this automated feature. I looked in the Nvidia control panel and there is nothing regard this issue, how is that possible?

The problem is in using SFML. Why wouldn't you create context on your own? (I'm allergic on wrappers/libraries.)
GL 2.1 context can be created as simple as calling wglCreateContext(). SFML probably uses wglCreateContextAttribsARB(), and it returns the highest supported version. wglCreateContext() cannot create higher that GL 2.1 context even if you want that.




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.