Jump to content

View more

Image of the Day

WIP title screen for #DeathOfAPartisan #screenshotsaturday #gamedev https://t.co/qJNhfZCvd4
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.

Sign up now

Triangle not visible but background colour does render

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 Fredericvo   Members   


Posted 03 March 2013 - 12:53 PM



I've finally decided to do the big step towards D3D11 from D3D9 and whoah it's a lot more overwhelming indeed.

I was a bit shocked to hear that D3DX was deprecated so decided to directly learn it the right (and hard) way without it.

Unfortunately every tutorial available, including the excellent Rastertek ones, seems to still use D3DX rather than DirectXmath.

I wanted to give it a try updating their tutorial to one that wouldn't require D3DX, even for compiling shaders and loading textures.

After battling with compilation errors the whole weekend I managed to finally compile without errors or warnings but.... Big disappointment.... It doesn't work when I run it. I can see the coloured background being cleared (set it to red on purpose as I wasn't sure the original black was the clear colour or just a fullscreen of plain nothingness lol. The triangle however isn't being rendered.

Very often beginners have problems with backface culling settings, or plain wrong transformations etc but this is from an existing tutorial that is known to work...


Here is what I did.

I replaced every D3DX type (e.g. D3DMATRIX, D3DVECTOR4, etc) with a new DirectXmath type (XMMATRIX,...)

I replaced the utility functions (D3DXMatrixRotateY,...) with equivalent XM functions too and adapted the parameters or other peculiarities that changed.

I removed runtime shader compilation (D3DXCompileFromFile) and instead embedded compiled shader files (*.cso) into the exe by using the resource compiler. Visual Studio 2012 itself uses FXC.EXE to compile the shaders along with the project. Very elegant solution.

During runtime I use FindResource/LoadResource/LockResource to get a pointer that CreateVertex/PixelShader can use.

I tried debugging extensively and all the pointers are being allocated and buffers created successfully so I assume it works.


One issue I had earlier was alignment errors on XM types and apparently compiling as x64 (which ultimately is also what everyone will have to do anyway in a near future) solved it. However, could it be that some variable size somewhere would need to be updated to a size_t or whatever to solve my problem? Or is it something else? I really can't find it which is why I decided to post my source here (well it's Rastertek's source with my updates)

If I can get this to work I might create an online tutorial as well and will credit whoever helped me here. Thanks.


EDIT: Before" RARing" the project to upoad it here I introduced a careless mistake due to which you probably got resource compiler errors... colorv.cso not found etc

I assumed I couldn't know if you'll compile under debug or release so attempted conditional compiling but it appears that #ifdef Debug or _Debug doesn't work at all at least on my system. To add insult to injury I misspelled a directory name (Debuge). 

If you compile under debug update the resource file to



#define RT_RCDATA 10
1000 RT_RCDATA "..\\x64\\Debug\\colorv.cso"
1001 RT_RCDATA "..\\x64\\Debug\\colorp.cso"
otherwise replace the directory names (Debug) by Release. It should compile now. (but it's not the fix for the original problem...)
Since the whole point is to find the error I suppose it's better to compile under Debug anyway.

Attached Files

Edited by Fredericvo, 04 March 2013 - 08:11 AM.

#2 Fredericvo   Members   


Posted 04 March 2013 - 09:48 AM

OK don't bother. I solved it myself.


It was again a careless mistake of the kind that happens when you use copy/paste to avoid typing too much.

Somewhere in the code I had these lines:



xmpos = DirectX::XMLoadFloat3(&position);
    xmla = DirectX::XMLoadFloat3(&lookAt);
    xmup = DirectX::XMLoadFloat3(&up);
but with &position 3 times.
Now it works perfectly.

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.