Jump to content

View more

Image of the Day

The night is still, but the invasion brings chaos. #screenshotsaturday #hanako #indiegame #gameart #ue4 #samurai https://t.co/cgILXuokoS
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

opengl window created by freeglut does not have title bar and frame

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
2 replies to this topic

#1 KhoaVN   Members   

316
Like
0Likes
Like

Posted 13 March 2013 - 04:28 AM

I am following tutorial from lazyfoo,net

I've finished the first lesson. Everything is OK, I mean there isnt any error in my code. I compiled successfully. However, my result looks like this:

no frame.png

 

My tool and my lib:

Windows 7 SP1 32bit ultimate

freeglut 2.8.0.1

MinGW (latest)

OpenGL 2.1

 

I dont kown how to fix it. Plz help. Thanks!


Edited by KhoaVN, 13 March 2013 - 04:30 AM.


#2 shacktar   Members   

1503
Like
0Likes
Like

Posted 13 March 2013 - 08:32 PM

This is the lesson you're referring to correct?

http://lazyfoo.net/SDL_tutorials/lesson01/index2.php

 

Assuming you're using that code verbatim (if you're not, please post the actual code used so that we can help you better), then perhaps the problem is with loading the image:

 

//Load image
hello = SDL_LoadBMP( "hello.bmp" );

 

Have you tried using the full path to hello.bmp?



#3 KhoaVN   Members   

316
Like
0Likes
Like

Posted 13 March 2013 - 08:50 PM

@shacktar: the tut that i followed was OpenGL not SDL smile.png It's here: http://lazyfoo.net/tutorials/OpenGL/01_hello_opengl/index2.php

I compiled the source code but there wasnt any error. Everything ran fine but the frame of window disappeared.

I tested the code from author. The window from that code has right frame (border).

 

I believed the error came from my code but why no error has been found when I compiled. Is it a semantic error? I compared 2 source code files and I saw they are not different.

 

Hic I go mad right now blink.png  smile.png


Edited by KhoaVN, 13 March 2013 - 08:52 PM.





Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.