Jump to content

View more

Image of the Day

Boxes as reward for our ranking mode. ヾ(☆▽☆)
#indiedev #gamedev #gameart #screenshotsaturday https://t.co/ALF1InmM7K
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.

Sign up now

I am no longer able to load a cube mesh correctly. How do I fix this problem?

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 asperatology   Members   


Posted 06 April 2013 - 02:50 AM

Wall of text below:


I'm having trouble loading up a correct cube mesh using OpenGL ES 2.0 on an Android device running ICS.


From what I observed, I see that the vertices of the cube is not only distorted, but also some of the vertices have incorrect vertex positions in the world matrix. You can tell by looking at some of the snapshots taken below:








I have checked and confirmed that my OBJ file parser is not causing any troubles, by comparing the values copied into the buffer objects to the values in the OBJ file itself. I have used the software, Blender, to re-create the cube mesh by exporting and overwriting the OBJ files. I have exclusively enabled "Triangulate faces" and "Include normal" in the Blender -> Export options. None of the actions above worked.


I have also checked my shader codes to see if they compiled and are referencing the correct variables. So far, there's nothing wrong. The OpenGL ES did not spit out any errors, when I was using glGetProgramInfo() and glGetShaderInfo(). They all pass. And I can see my model clearly, just that I didn't add any ambient lighting and shadows to the mesh.


I have somehow recreated the problem that I had asked a month ago prior that was solved by fixing the transformation matrix calculation methods. But this time, it's no longer the matrices. I have checked and confirmed that the transformation matrices are not causing the problem.


The cube that was exported/overwritten is the same cube mesh I had used in the Stack Overflow question above. Which looked like this below: (Left side: Perspective view of the back side of the cube mesh. Right side: Orthogonal view of the front size of the cube mesh.)




Below is an attachment of the Android APK, packed in a ZIP file.


Attached File  3DOpenGL.zip   445.99KB   46 downloads


Below is the project source file attached:


Attached File  3DOpenGL_source.zip   3.38MB   56 downloads


And below are some of the source code that I used to load the cube mesh model:  (Model class, OBJ model loader static method) They are shown for easier lookup.


package models;

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.nio.ByteBuffer;
import java.nio.ByteOrder;
import java.nio.FloatBuffer;
import java.nio.ShortBuffer;
import java.util.ArrayList;
import android.content.Context;
import android.content.res.AssetManager;
import android.util.Log;

public class Model {
	protected FloatBuffer vertexBuffer;
	protected ShortBuffer indexBuffer;
	public static Model loadOBJModel(Context c, String filename) {
		ArrayList<Float> tempVertices = new ArrayList<Float>();
		ArrayList<Float> tempNormals = new ArrayList<Float>();
		ArrayList<Short> tempVertexIndices = new ArrayList<Short>();
		ArrayList<Short> tempNormalIndices = new ArrayList<Short>();
		Model model = new Model();
		try {
			AssetManager manager = c.getAssets();
			BufferedReader reader = new BufferedReader(new InputStreamReader(manager.open(filename)));
			String line;
			while ((line = reader.readLine()) != null) {
				if (line.startsWith("v")) {
					for (int i = 0; i < 3; i++) {
						tempVertices.add(Float.valueOf(line.split(" ")[i + 1]));
				else if (line.startsWith("vn")) {
					for (int i = 0; i < 3; i++) {
						tempNormals.add(Float.valueOf(line.split(" ")[i + 1]));
				else if (line.startsWith("f")) {
					String[] tokens = line.split(" ");
					if (tokens[1].contains("/")) {
						for (int i = 0; i < 3; i++) {
							tempVertexIndices.add(Short.valueOf(tokens[i + 1].split("/")[0]));
							tempNormalIndices.add(Short.valueOf(tokens[i + 1].split("/")[2]));
					else {
						for (int i = 0; i < 3; i++) {
							tempVertexIndices.add(Short.valueOf(tokens[i + 1]));
			//TODO: Will add lighting back once everything is confirmed to work properly.
			float[] vertices = createFloatArray(tempVertices);
			//float[] normals= createFloatArray(tempNormals);
			short[] vertexIndices = createShortArray(tempVertexIndices);
			//short[] normalIndices = createShortArray(tempNormalIndices);
			model.vertexBuffer = ByteBuffer.allocateDirect(vertices.length * 4).order(ByteOrder.nativeOrder()).asFloatBuffer();
			model.indexBuffer = ByteBuffer.allocateDirect(vertexIndices.length * 2).order(ByteOrder.nativeOrder()).asShortBuffer();
		catch (Exception e) {
			Log.e("DEBUG loadCube()", "Exception error caught.", e);
		return model;
	private static float[] createFloatArray(ArrayList<Float> list) {
		float[] array = new float[list.size()];
		for (int i = 0; i < array.length; i++) {
			Float f = list.get(i);
			array[i] = (f != null ? f : Float.NaN);
		return array;
	private static short[] createShortArray(ArrayList<Short> list) {
		short[] array = new short[list.size()];
		for (int i = 0; i < array.length; i++) {
			Short f = list.get(i);
			array[i] = (f != null ? f : 0);
		return array;


Below is the Cube class: (Cube class, with transformation matrices, vertex and fragment shader codes, and the initialization)


package models;

import java.util.Arrays;
import android.content.Context;
import android.opengl.GLES20;
import android.opengl.Matrix;
import android.util.Log;

public class Cube {
	private String vertexCode = "" +
			"attribute vec4 a_position;              	\n" +
			"uniform mat4 u_mvpMatrix;                	\n" +
			"void main() {                           	\n" +
			"	gl_Position = u_mvpMatrix * a_position;	\n" +
			"}                         					\n";
	private String fragmentCode = "" +
			"precision mediump float;                   \n" +
			"void main() {                              \n" +
			"	gl_FragColor = vec4(0.0, 1.0, 0.0, 1.0);\n" +
			"}                                          \n";
	private int shaderProgram;
	private int attribute_Position;
	private int uniform_mvpMatrix;
	private float angle;
	private Model model;
	public Cube(Context c, String filename){
		model = Model.loadOBJModel(c, filename);
	public void setup(){
		int vertexShader = GLES20.glCreateShader(GLES20.GL_VERTEX_SHADER);
		GLES20.glShaderSource(vertexShader, vertexCode);
		int fragmentShader = GLES20.glCreateShader(GLES20.GL_FRAGMENT_SHADER);
		GLES20.glShaderSource(fragmentShader, fragmentCode);
		shaderProgram = GLES20.glCreateProgram();
		GLES20.glAttachShader(shaderProgram, vertexShader);
		GLES20.glAttachShader(shaderProgram, fragmentShader);
		GLES20.glBindAttribLocation(shaderProgram, 1, "a_position");
		int[] linked = new int[1];
		GLES20.glGetProgramiv(shaderProgram, GLES20.GL_LINK_STATUS, linked, 0);
		if (linked[0] == 0) {
			Log.e("DEBUG setup()", "Shader code error.");
			Log.e("DEBUG setup()", GLES20.glGetProgramInfoLog(shaderProgram));
		attribute_Position = GLES20.glGetAttribLocation(shaderProgram, "a_position");
		uniform_mvpMatrix = GLES20.glGetUniformLocation(shaderProgram, "u_mvpMatrix");
	public void draw(float[] mMatrix, float[] vMatrix, float[] pMatrix){
		float[] mvpMatrix = new float[16];
		Matrix.setIdentityM(mMatrix, 0);
		Matrix.translateM(mMatrix, 0, 0f, -2.5f, -1.5f);
		Matrix.rotateM(mMatrix, 0, angle, 0f, 1f, 0f);
		// This is the transformation matrices that I had a problem with a month ago. It has been solved by using
		// an array copy of the original matrix. The behavior is already defined in the Android documentation.
		Matrix.multiplyMM(mvpMatrix, 0, vMatrix, 0, mMatrix, 0);
		Matrix.multiplyMM(mvpMatrix, 0, pMatrix, 0, Arrays.copyOf(mvpMatrix, 16), 0);
		GLES20.glVertexAttribPointer(attribute_Position, 3, GLES20.GL_FLOAT, false, 3 * 4, model.vertexBuffer);
		GLES20.glUniformMatrix4fv(uniform_mvpMatrix, 1, false, mvpMatrix, 0);
		GLES20.glDrawElements(GLES20.GL_TRIANGLES, model.indexBuffer.capacity(), GLES20.GL_UNSIGNED_SHORT, model.indexBuffer);
		angle = ++angle % 360f;


Oh boy, there's a lot of information provided just so I can nail this bug, squish it, and move on. I really need help on this one. Been looking for answers on Google search, and came up dry. The first three results are not what I wanted. The second result is the link that I asked for solutions a month ago. The rest of the results are tutorials.


If there's something I might have missed. Please let me know.

Edited by tom_mai78101, 06 April 2013 - 03:01 AM.

#2 Sponji   Members   


Posted 06 April 2013 - 11:19 AM

There are at least two bugs in your model loading code:



What happens to lines with which start with "vn"? "vn" startsWith "v". This doesn't really matter right now, but you get unnecessary vertices, which are actually normals.


tempVertexIndices.add(Short.valueOf(tokens[i + 1].split("/")[0]));

You have to subtract one from the index numbers, because obj format starts counting indices from 1 instead of 0.


Hope this helps.

Edited by Sponji, 06 April 2013 - 11:21 AM.


#3 asperatology   Members   


Posted 06 April 2013 - 04:24 PM

I'm currently debugging this problem, along with your tips.


 can also take in "v", "vn", and possibly "vt"? I did not know that...




Another question that I'm more confused is when the index buffer is read, does the index numbers in the buffers have to start off like:


0, 1, 2, 3, 4,...


And not the other way around?


1, 2, 3, 4, 5,...


I thought the index number and the vertex element in OpenGL ES reads the same, and that OpenGL ES automatically chooses the index element position accordingly. I'm checking this as I go.

#4 L. Spiro   Members   


Posted 06 April 2013 - 07:05 PM

That is not what he means.

The values of the indices inside the .OBJ file are 1 greater than they should be (I seriously don’t understand the purpose of this—shame on the creators of .OBJ for what seems to be a newbie trap and nothing more), which means in order to make it useful to your program you need to subtract 1 from that value, not add one.



L. Spiro

#5 asperatology   Members   


Posted 07 April 2013 - 01:08 PM

Thanks again for your input. I've now fully understood what all of you were saying.


I finally got the free time to continue debugging, and it looks like using:

String.startsWith(String prefix);

Is a bad idea. I've changed it to doing:


String header = line_read_from_input.split(" ")[0];
header.equals(String prefix);

So it's always correct.


Everything is now perfect. Life is good. Thanks to all and all a good night.

Edited by tom_mai78101, 07 April 2013 - 01:09 PM.

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.