Jump to content

View more

Image of the Day

WIP title screen for #DeathOfAPartisan #screenshotsaturday #gamedev https://t.co/qJNhfZCvd4
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

GLSL texture.rgb showing up as black

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
2 replies to this topic

#1 polyfrag   Members   

2479
Like
0Likes
Like

Posted 04 August 2013 - 08:28 AM

When I use only the .xyz or .rgb part of the texel, the PNG transparent image is showing up as black. Why? When I use all 4 components it shows up correctly though.

 

I'm saving the alpha channel for bump information for heightmap texture blending. I saved the transparent PNG as a JPG and the .xyz component shows up fine.

 

I'm using a Quadro card.


Edited by polyfrag, 04 August 2013 - 08:46 AM.


#2 polyfrag   Members   

2479
Like
0Likes
Like

Posted 04 August 2013 - 09:08 AM

Oh, it appears to have removed the RGB information when I went "colour to alpha" in GIMP.



#3 deftware   Prime Members   

1778
Like
1Likes
Like

Posted 04 August 2013 - 01:32 PM

silly head






Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.