Jump to content

View more

Image of the Day

雑魚は多めにして、爽快感重視にしつつ・・・(´・ω・`)
早いとこ、ベースを作って、完成にもっていかないとね。
タイトルもまだ迷ってるだよなぁ。 
#indiedev  #indiegame #screenshotsaturday https://t.co/IwVbswGrhe
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Crashes upon device creation

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
No replies to this topic

#1 maxest   Members   

614
Like
0Likes
Like

Posted 09 September 2013 - 07:04 AM

I have a problem with creating a D3D11 device. On one computer which has long been not formatted (probably a lot of libs and stuff like that installed) my app works fine. On another computer, which is a clean Win7 x64 installation, I compiled my app and it crashes upon device creation, that is, D3D11CreateDevice returns a null pointer to the device. I've already updated my Windows with various updates etc. but that has not helped. Any idea?

 

I remember I had the same problem on another computer when I tried to create the device with D3D11_CREATE_DEVICE_DEBUG flag. Without this flag it was all fine. But now it crashes no matter whether this flag is on or off.

 

[EDIT]

I've just updated Windows 8 SDK and the device creation process goes fine. Now, when I try to run my app via F5 key (Debug mode) it crashes upon swap chain creation. But, when I run the build with DEBUG -> Graphics -> Start Diagnostics (Alt + F5) everything is fine. Any idea why "regular" F5 doesn't work?


Edited by maxest, 09 September 2013 - 08:59 AM.





Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.