Jump to content

View more

Image of the Day

#ld38 #screenshotsaturday Mimosa Fizz action gif #2 https://t.co/TUzdppvfUL
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

OpenGL Texture issues

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
1 reply to this topic

#1 kennycastro007   Members   

105
Like
0Likes
Like

Posted 12 August 2014 - 04:28 PM

I've been having a very weird problem with my textures in my project. What's happening is that the pixels that my shaders are choosing to place on my object are dependent on where the object is in my window. When I have the object stationary on the screen I don't notice it, but once I start moving the object around the screen via glBufferSubData, I notice that the texture starts changing. Does anyone have any Idea of why this is happening? The whole texture won't bind completely onto the object either, I always end up getting only part of the image onto the object?



#2 SeanMiddleditch   Members   

17493
Like
1Likes
Like

Posted 12 August 2014 - 06:41 PM

A picture is worth a thousand words. Sounds like your UVs aren't being updated or passed in to the shader correctly, though.

Game Developer, C++ Geek, Dragon Slayer - http://seanmiddleditch.com

C++ SG14 "Games & Low Latency" - Co-chair - public forums

Wargaming Seattle - Lead Server Engineer - We're hiring!





Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.