Jump to content

View more

Image of the Day

#ld38 #screenshotsaturday Mimosa Fizz action gif #2 https://t.co/TUzdppvfUL
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

[android] Weird performance for simple scene

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
No replies to this topic

#1 eduardo_costa   Members   

349
Like
0Likes
Like

Posted 02 September 2014 - 01:07 PM

Hey all!
I'm developing an engine in both WebGL and Android native using Haxe.
There is some strange performance issue happening though.

Running a simple example with 300 cubes in WebGL it runs at 60fps in Chrome Desktop and 30fps in Chrome Beta in my Nexus4.

300 cubes demo.
https://dl.dropboxusercontent.com/u/...0_1/index.html

Now. I'm also compiling the same demo in Android Java and generating an APK.
But the APK is running at 20-30fps top.
Considering that it is native, the performance shouldn't be above WebGL at least?

* If requested I can provide the APK too. *

## Extra Info ##

- Nexus4 Phone with latest android update.

- Haxe compiles its "Float" type into Java's "double".
- Cube shader is alpha blended and have 'discard' commands.
- GLSurfaceView 'isHardwareAccelerated' flag returns true.
- Tracing the GLES calls during render I'm issuing just a Uniform(WorldMatrix) + DrawArrays(TRIANGLES) per Cube (so 300 total)






Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.