Jump to content

View more

Image of the Day

#ld38 #screenshotsaturday Mimosa Fizz action gif #2 https://t.co/TUzdppvfUL
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Static Sound

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
2 replies to this topic

#1 daBomb   Members   

122
Like
Likes
Like

Posted 19 January 2000 - 10:46 AM

When using my DirectSound application all I can get it to play is static, and not my wav file. Does anyone have any suggestions as to what could be the problem. A little backgound info to the problem. I did not create my own primary buffer, I am using the one created by Direct Sound. I have error checking on everything my function that creates the sound buffer holding my sound, and nothing appears to be giving a problem. Any help would be great. At this point, I''m thinking that the game doesn''t really need sound anyway!!! :-)

#2 Anonymous Poster_Anonymous Poster_*   Guests   

Likes

Posted 19 January 2000 - 04:32 PM

Well, first check if you have set the sound format of the buffer correctly, or if you are loading the wav in the right way... would help if you say what flags you set for the buffer, the sound format, etc. I think the problem is that your wav file can be compressed; the DirectX 5 doesnt support wav compression (dont know about other versions).

#3 daBomb   Members   

122
Like
Likes
Like

Posted 20 January 2000 - 01:55 AM

Thanks for your advice, I never consider the fact that it could be compressed, and know that I think about it, that very well could be the problem. Thanks again.




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.