Jump to content

View more

Image of the Day

Boxes as reward for our ranking mode. ヾ(☆▽☆)
#indiedev #gamedev #gameart #screenshotsaturday https://t.co/ALF1InmM7K
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Re-Initializing OpenGL = No Depth Buffer

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
1 reply to this topic

#1 SGreth   Members   

218
Like
Likes
Like

Posted 22 November 2001 - 04:17 PM

Happy T-Day Everyone! I''m trying to re-initialize the display in a new resolution but to no avail! When my scene comes back it appears that I have no depth buffer! I don''t want to post my code here, but I''m pretty much using NeHe''s cleanup code and init code (some mods here and there). Yes, I''ve enabled depth testing after I re-init and yes, I did set the depth buffer value in the pixel format descriptor. I''ve gone as far as to actaully destroy the window, un-register the windows class, let go of the DC and RC, and also re-initialize those. I''ve pretty much killed everything and re-initialized all the right stuff! Any help would be greatly appreciated! Thanks, ~Rob

#2 SGreth   Members   

218
Like
Likes
Like

Posted 22 November 2001 - 04:51 PM

Grrr...So, after poking through some of my co-coders code I found out that his dialog box code gracefully disables depth buffering and didn''t bother to reset the state Yucky for me as you can imagine! Oh well, another day, another lesson!
Thanks everyone and enjoy the holliday weekend!
~Rob




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.