Jump to content

View more

Image of the Day

Adding some finishing touches...
Follow us for more
#screenshotsaturday #indiedev... by #MakeGoodGames https://t.co/Otbwywbm3a
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

Anyone else get regular errors when entering the site?

4: Adsense
  • You cannot reply to this topic
11 replies to this topic

#1 Embassy of Time   Members   

448

Posted 12 April 2017 - 12:34 PM

I keep getting errors when trying to go to gamedev.net. Mostly they are SQL error messages, but they are so frequent I have to wonder if it's me or the site? I get them on both laptop and phone, although they use completely different networks.



#2 phil_t   Members   

Posted 12 April 2017 - 02:33 PM

I don't see any SQL error messages, but several warnings in my browser's console. And the page keeps spinning until it fails to load index.php (e.g. on this page, https://www.gamedev.net/topic/687886-anyone-else-get-regular-errors-when-entering-the-site/index.php )



#3 Nypyren   Members   

Posted 12 April 2017 - 07:25 PM

I saw one site-is-down message earlier today, but other than that it's been pretty stable.

#4 Mike2343   Members   

Posted 12 April 2017 - 08:01 PM

I saw one site-is-down message earlier today, but other than that it's been pretty stable.

I can get that one several times a day.  Saying maintenance.  Tried on my phone then laptop and finally my PC, all had the same.  But it was like 11am PST.



#5 grumpyOldDude   Members   

Posted 13 April 2017 - 03:33 AM

You're talking about this, yeah i got this a lot for a while. But most recently it has eased off a lot and haven't had it for days now.

Untitled5.png


can't help being grumpy...

Just need to let some steam out, so my head doesn't explode... 


#6 wintertime   Members   

Posted 13 April 2017 - 05:58 AM

I had alternating 503 Errors, SQL Errors without detailed error message and maintenance notices, not sure if yesterday or 2 days ago.



#7 Khawk   Senior Staff   

Posted 13 April 2017 - 08:35 AM

We were having some server issues. I think it's been resolved, but let me know if you continue to see them. With the most recent changes in configuration the site might load a little slower, but at least it'll load.

For the technically curious, we're replicating data to another server running our site upgrade. This has introduced a new load on the current server, and when combined with increasing traffic started to lead to out-of-memory and/or max connection issues. A lot of tweaking between apache and mysql lately to find the right balance.



#8 Embassy of Time   Members   

448

Posted 15 April 2017 - 06:30 AM

We were having some server issues. I think it's been resolved, but let me know if you continue to see them. With the most recent changes in configuration the site might load a little slower, but at least it'll load.

For the technically curious, we're replicating data to another server running our site upgrade. This has introduced a new load on the current server, and when combined with increasing traffic started to lead to out-of-memory and/or max connection issues. A lot of tweaking between apache and mysql lately to find the right balance.

That sounds about right. The examples others have given here look like what I get, too, so it's probably that.

No virus for me to clean out this time. Phew!



#9 fleabay   Members   

800

Posted 15 April 2017 - 05:57 PM

I keep getting errors when trying to go to gamedev.net. Mostly they are SQL error messages, but they are so frequent I have to wonder if it's me or the site? I get them on both laptop and phone, although they use completely different networks.


Someone has tried to implement a security method for sql injection by stripping out the opening html bracket.

What you are seeing is broken html. I see it also.

#10 Daixiwen   Members   

609

Posted 20 April 2017 - 12:24 AM

I still see the SQL error message when trying to reach gamedev on http. The site is working fine when using https.

I know we are all moving to https and I've updated my bookmark, but if there is no plan to make the non-tls version of the site working again maybe it should redirect to the tls version instead of giving an error?


Definition of a man-year: 730 people trying to finish the project before lunch

#11 Khawk   Senior Staff   

Posted 20 April 2017 - 12:53 AM

http redirects to https already. I think you just caught the legit SQL error for this evening.

RE: this SQL problem. I won't go into the details why these are happening right now. It's a combination of server configuration and custom software issues that have actually been happening for a long time but hidden by patchwork. Suffice to say it's more worthwhile at this point to put as much time as possible into getting the new setup ready. More configuration changes were made today so the errors should be less frequent than they have been, but I'll continue to monitor the situation and do what I can to minimize disruption.



#12 VigiloLupus   Members   

111

Posted 22 April 2017 - 11:03 AM

I haven't had any issues