Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Monder

Reseting Root Password

This topic is 5652 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

A few days ago I installed slackware 8.0. I use grub to boot it and I didn''t install that till today. So I used grub to boot up slackware and everything was ok. I then tried to login as root but I couldn''t remember the password. I have an RH admin survival cd so I can boot up a minimal system and mount my slackware drive. I did this went to the /etc/passwd file and there was a line that begined with root:x: I assumed x meant the password was located in a shadow file so I set it to * cause I though this meant no password so I had this root:*: However when I booted up slackware I tried to login as root with a blank password it didn''t work. Can anyone please tell me what else I have to do to remove the root password?

Share this post


Link to post
Share on other sites
Advertisement
You could try to run a brute-force cracker (like John the Ripper) on your /etc/shadow file.

Share this post


Link to post
Share on other sites
I''m pretty sure that * is the marker for a disabled account. You should be able to change the root password with your CD (or just use lilo or whatever to boot into single-user mode). At that point you have total control of the system anyway, and you can hash your desired password, and manually put it into the passwd file.

Share this post


Link to post
Share on other sites
All I had to do was not put anything in the password field so I had this

root::

This took off the password and I logged in as root and set a new one. Thanks anyway guys

Share this post


Link to post
Share on other sites
Boot linux into single user mode and you won''t be asked for a password at all. I don''t know if Grub has anything like Lilo does for passing arguments, but typing "linux single" at the LILO: prompt did it for me.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!