Sign in to follow this  
izzo

visual studio .net 2003 grrrrrr

Recommended Posts

Argh!!! Is it just me or was Visual Studio 6 the last rock solid VS? The VS.NET IDEs seem so clunky and wishy washy. I use VS.NET 2002 at home and VS.NET 2003 at work and both of them tend to exhibit Builderisms many times throughout the day. Builderisms are a strange phenomenon that anyone familiar with Borland's C++ Builder should have experienced. Things like the cursor disappears; dialogs stop responding for minutes at a time; things like that. Well VS.NET seems to do stuff like that all the time for me. Are there service packs out that I don't know about? It even happens when I'm running nothing else at all! ARGH!@@# sam

Share this post


Link to post
Share on other sites
I had the same impression with VS .NET through the first month or so of working with it. In particular, launching the MSDN help for the first time per-session was down-right arduous. I've found that disabling Windows XP's System Restore feature dramatically improved VS .NET's responsiveness. I have no explanation why, but maybe that will help in your case too. [Control Panel] > [System] > [System Restore]

Whenever I mention that to people, they usually say "oh yeah, I disabled that a long time ago.", but I tend to be a bit behind the times in terms of Windows mod'ing. If that's the case here -- then I've got nothing that will help!

Visual Studio itself is all managed code, right? That would explain away some of the lack of responsiveness at times. Reminds of those Java IDE's written in Java.

Share this post


Link to post
Share on other sites
The project that I'm working on at work is large (I think.. at least, compared to what I work on at home it is); the solution has 13 projects in it and a total of about 300 source files.

I can't always exactly reproduce these problems but one that seems to happen semi-frequently is the editor window stops responding for about a minute sometimes when it hits a breakpoint. I can't scroll around, can't type, can't select text.

Actually today these things were happening while I was trying to remote debug a vmware virtual machine, and vmware seems to chew up a lot of CPU. Maybe that has something to do with it.. (my work machine is an Athlon 1.1ghz with 512mb RAM).

Hmm, I had forgotten to turn off system restore actually. I just turned it off; maybe it will make a difference!

cheers
sam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this