Jump to content
  • Advertisement
Sign in to follow this  
tonysameh

OpenGL glEnable(GL_POINT_SMOOTH) but the points are still square

This topic is 3256 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

My text book said that some openGL distributions will still draw square points after this line. It looks like that's my case. Now how can I upgrade my distribution (or version)? I used the following lines: glPointSize(6); // Points are n pixels in diameter glEnable(GL_POINT_SMOOTH); glHint(GL_POINT_SMOOTH_HINT, GL_NICEST); glEnable(GL_BLEND); glBlendFunc(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA); glBegin(GL_POINTS); glVertex2f( 1.0, 1.0 ); glVertex2f( 2.0, 1.0 ); glVertex2f( 2.0, 2.0 ); glEnd();

Share this post


Link to post
Share on other sites
Advertisement
Unless going with a software rasterizer (in which case Mesa is an option) is out of the question, your only chance is the driver. If updating the graphics driver doesn't "fix" this, then chances are your manufacturer just doesn't focus on round points, so getting a new graphics card from another manufacturer would be the second step.

That, however, excludes all other options to get smooth dots, like manually drawing discs or textured objects instead of actual point primitives.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!