Jump to content

View more

Image of the Day

The night is still, but the invasion brings chaos. #screenshotsaturday #hanako #indiegame #gameart #ue4 #samurai https://t.co/cgILXuokoS
IOTD | Top Screenshots

The latest, straight to your Inbox.

Subscribe to GameDev.net Direct to receive the latest updates and exclusive content.


Sign up now

DX11 Fullscreen.

4: Adsense

Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
2 replies to this topic

#1 BornToCode   Members   

1185
Like
0Likes
Like

Posted 10 January 2014 - 11:16 AM

I can go to fullscreen fine. But whenever i press the window key on the keyboard or click on another window in a different monitor. It drops out of fullscreen and goes into window mode. Is there anyway i can force it to stay in fullscreen mode no matter what.

 

Thanks.



#2 ericrrichards22   GDNet+   

2384
Like
0Likes
Like

Posted 10 January 2014 - 12:26 PM

I would start looking at your windows message handler to see if you're getting WM_ACTIVATE or WM_SIZE events and possibly doing the full-screen switch yourself in error.


Eric Richards

SlimDX tutorials - http://www.richardssoftware.net/

Twitter - @EricRichards22


#3 Vladimir128   Members   

229
Like
0Likes
Like

Posted 10 January 2014 - 02:12 PM

Yes, try to do that, and when you get the message, check if your application was activated and call the method IDXGISwapChain::SetFullscreenState with parameter Fullscreen set to TRUE. That should work :)






Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.